]> git.sesse.net Git - vlc/blobdiff - debian/rules
* Makefile.am: include the vlm html files in the win32 package.
[vlc] / debian / rules
index 4a27d26251f0ea279aac848950a5a37cb3f0aa5e..f9648e6ba0a9eaf2586b3602926d370006cc07cf 100755 (executable)
@@ -1,6 +1,6 @@
 #!/usr/bin/make -f
-# debian/rules for the VideoLAN Client - uses debhelper.
-# $Id: rules,v 1.109 2004/01/04 04:53:07 sam Exp $
+# debian/rules for the VLC media player - uses debhelper.
+# $Id$
 # based on Joey Hess's one.
 
 # Uncomment this to turn on verbose mode.
@@ -39,20 +39,26 @@ CONFIG_FLAGS += \
        --enable-wxwindows \
        --enable-slp \
        --enable-flac \
-       --enable-skins \
+       --disable-skins \
        --disable-basic-skins \
+       --enable-skins2 \
        --enable-freetype \
        --enable-mkv \
        --enable-v4l \
        --enable-pvr \
        --enable-speex \
        --enable-caca \
+       --enable-livedotcom \
+       --enable-libmpeg2 \
+       --enable-dts \
+       --enable-fribidi \
+       --enable-cdio \
+       --enable-mod \
        $(NULL)
 
 # These ones are currently shipped with VLC
 CONFIG_FLAGS += --enable-ffmpeg --with-ffmpeg-tree=extras/ffmpeg
 CONFIG_FLAGS += --enable-faad --with-faad-tree=extras/faad2
-CONFIG_FLAGS += --enable-libmpeg2 --with-libmpeg2-tree=extras/mpeg2dec
 
 # Glide and svgalib are only for x86
 ifeq ($(shell dpkg-architecture -qDEB_BUILD_GNU_CPU),i386)
@@ -77,24 +83,24 @@ configure-stamp:
        dh_testdir
 
        # Touch stuff
-       touch configure.ac \
-       && touch aclocal.m4 \
-       && touch configure \
-       && touch config.h.in \
-       && touch `find . -name Makefile.in`
+       touch configure.ac
+       touch aclocal.m4
+       touch configure
+       touch config.h.in
+       touch `find . -name Makefile.in`
 
        # Check that we have an ffmpeg tree in here (can be a symlink)
        test -d extras/ffmpeg
-       if test ! -d CVS; then \
+       if test ! '(' -d CVS -o -d .svn ')'; then \
          cd extras/ffmpeg \
-         && ./configure --enable-pp \
+         && CC=$(CC) ./configure --enable-pp --enable-gpl --enable-zlib --disable-debug \
          && cd libavcodec \
          && $(MAKE); \
        fi
 
        # Check that we have an faad2 tree in here (can be a symlink)
        test -d extras/faad2
-       if test ! -d CVS; then \
+       if test ! '(' -d CVS -o -d .svn ')'; then \
          cd extras/faad2 \
          && touch `find . -name configure.in` \
          && touch `find . -name aclocal.m4` \
@@ -106,21 +112,6 @@ configure-stamp:
          && $(MAKE); \
        fi
 
-       # Check that we have an mpeg2dec tree in here (can be a symlink)
-       test -d extras/mpeg2dec
-       if test ! -d CVS; then \
-         cd extras/mpeg2dec \
-         && touch configure.in \
-         && touch aclocal.m4 \
-         && touch acinclude.m4 \
-         && touch configure \
-         && touch `find . -name config.h.in` \
-         && touch `find . -name Makefile.in` \
-         && ./configure --disable-shared \
-         && cd libmpeg2 \
-         && $(MAKE); \
-       fi
-
        # Configure VLC
        ./configure --mandir=$${prefix}/share/man \
          --infodir=$${prefix}/share/info $(CONFIG_FLAGS)
@@ -138,7 +129,7 @@ build-stamp:
 
 ifneq ($(shell dpkg-architecture -qDEB_BUILD_GNU_CPU),i386)
        # Hackety hackety hack
-       if test ! -d CVS; then \
+       if test ! '(' -d CVS -o -d .svn ')'; then \
          cd extras/ffmpeg/libavcodec \
          && $(MAKE) clean \
          && rm -f Makefile.pic \
@@ -148,18 +139,11 @@ ifneq ($(shell dpkg-architecture -qDEB_BUILD_GNU_CPU),i386)
        fi
 
        # HACKETY HACKETY HACK
-       if test ! -d CVS; then \
+       if test ! '(' -d CVS -o -d .svn ')'; then \
          cd extras/faad2/libfaad \
          && $(MAKE) clean \
          && $(MAKE) AM_CFLAGS=-fPIC; \
        fi
-
-       # HACK ME PLENTY MORE!!!
-       if test ! -d CVS; then \
-         cd extras/mpeg2dec/libmpeg2 \
-         && $(MAKE) clean \
-         && $(MAKE) LIBMPEG2_CFLAGS=-fPIC; \
-       fi
 endif
 
        # Build all the rest, with the PIC libs
@@ -174,16 +158,16 @@ clean:
 
        # Check that we have an ffmpeg tree in here (can be a symlink)
        test -d extras/ffmpeg
-       -if test ! -d CVS; then cd extras/ffmpeg && $(MAKE) distclean; fi
+       -if test ! '(' -d CVS -o -d .svn ')'; then \
+         cd extras/ffmpeg && $(MAKE) distclean; \
+       fi
        # Check that we have an faad2 tree in here (can be a symlink)
        test -d extras/faad2
-       -if test ! -d CVS; then cd extras/faad2 && $(MAKE) distclean; fi
-       # Check that we have an mpeg2dec tree in here (can be a symlink)
-       test -d extras/mpeg2dec
-       -if test ! -d CVS; then cd extras/mpeg2dec && $(MAKE) distclean; fi
+       -if test ! '(' -d CVS -o -d .svn ')'; then \
+         cd extras/faad2 && $(MAKE) distclean; \
+       fi
 
        # Removed ugly cruft
-       rm -f extras/mpeg2dec/include/mpeg2dec
        rm -f src/misc/modules_builtin.h
        rm -f mozilla/vlcintf.xpt mozilla/vlcintf.h
 
@@ -211,6 +195,9 @@ install: build
        #cp doc/fortunes.txt debian/vlc/usr/share/games/fortunes/vlc
        #strfile doc/fortunes.txt debian/vlc/usr/share/games/fortunes/vlc.dat
 
+       rm -Rf debian/vlc/usr/share/vlc/skins
+       ln -s vlc.1.gz debian/vlc/usr/share/man/man1/svlc.1.gz
+
        # Package: libvlc0-dev
        mv debian/vlc/usr/bin/vlc-config debian/libvlc0-dev/usr/bin/
        mv debian/vlc/usr/lib/*.a debian/libvlc0-dev/usr/lib/
@@ -321,6 +308,11 @@ endif
        # Package: mozilla-plugin-vlc
        ln -s vlc debian/mozilla-plugin-vlc/usr/share/doc/mozilla-plugin-vlc
        mv debian/vlc/usr/lib/mozilla debian/mozilla-plugin-vlc/usr/lib
+       # links for firefox
+       mkdir -p debian/mozilla-plugin-vlc/usr/lib/mozilla-firefox/plugins/
+       ln -s ../../mozilla/plugins/libvlcplugin.so debian/mozilla-plugin-vlc/usr/lib/mozilla-firefox/plugins/
+       mkdir -p debian/mozilla-plugin-vlc/usr/lib/mozilla-firefox/components/
+       ln -s ../../mozilla/components/vlcintf.xpt debian/mozilla-plugin-vlc/usr/lib/mozilla-firefox/components/
 
        # Package: kvlc
        mv debian/vlc/usr/bin/kvlc debian/kvlc/usr/bin/
@@ -342,16 +334,10 @@ endif
 
        # Package: wxvlc
        mv debian/vlc/usr/bin/wxvlc debian/wxvlc/usr/bin/
-       mv debian/vlc/usr/bin/svlc debian/wxvlc/usr/bin/
        ln -s vlc debian/wxvlc/usr/share/doc/wxvlc
        mv debian/vlc/usr/lib/vlc/gui/libwxwindows_plugin.so \
          debian/wxvlc/usr/lib/vlc/gui/
-       mv debian/vlc/usr/lib/vlc/gui/libskins_plugin.so \
-         debian/wxvlc/usr/lib/vlc/gui/
-       mv debian/vlc/usr/share/vlc/skins \
-         debian/wxvlc/usr/share/vlc/
        ln -s vlc.1.gz debian/wxvlc/usr/share/man/man1/wxvlc.1.gz
-       ln -s vlc.1.gz debian/wxvlc/usr/share/man/man1/svlc.1.gz
 
        # Clean up
        rm -f debian/vlc/$(VIDDIR)/*.png