]> git.sesse.net Git - vlc/blobdiff - debian/woody-buildpackage
- modules/gui/skins/skin_main.cpp: Try to open the default XML file first
[vlc] / debian / woody-buildpackage
index 2e1f6f9484dfc4d9a2b23078d735acf6cdaaa7b5..72be306925f3c18696c15c79a5d3d5d24758d1a3 100755 (executable)
@@ -1,6 +1,6 @@
 #! /bin/sh
 
-# $Id: woody-buildpackage,v 1.7 2003/02/17 07:22:05 sam Exp $
+# $Id: woody-buildpackage,v 1.12 2003/04/01 16:13:39 sam Exp $
 # Build VLC for a Woody Debian system
 
 if test ! -d debian
@@ -11,20 +11,37 @@ fi
 
 # changelog: replace (1.2.3-4) with (1.2.3-0woody.4)
 sed -e 's/^vlc (\([^)]*\)-\([^-)]*\))/vlc (\1-0woody.\2)/' \
+    -e 's/ unstable; / stable; /' \
     < debian/changelog > debian/changelog.woody
 
 # control: replace liba52-*-dev with a52dec-dev (>=0.7.3)
 #                  libdv*-dev with libdv-dev
 #                  kdelibs4-dev with kdelibs-dev
+#                  libqt3-mt-dev libqt3-compat-headers with libqt-dev
 #                  libarts1-dev with libarts-dev
+#                  libdvdread3-dev with libdvdread2-dev
+#                  libdvdplay0-dev (>=1.0.1-2) with libdvdplay0-dev
 #          remove libwxgtk2.4-dev
+#                 libflac-dev
+#                 libidl0 (workaround for mozilla-dev's bad deps)
+#                 libglib2.0-0 (workaround for mozilla-dev's bad deps)
+#          change Section: gnome with Section: graphics
+#                 Section: kde with Section: kde
 sed -e 's/liba52-[^-]*-dev/a52dec-dev (>=0.7.3)/' \
     -e 's/libdv[0-9]*-dev/libdv-dev/' \
     -e 's/kdelibs[0-9]*-dev/kdelibs-dev/' \
-    -e 's/libqt[0-9]*-dev/libqt-dev/' \
+    -e 's/libqt[0-9]*-mt-dev/libqt-dev/' \
+    -e 's/, libqt[0-9]*-compat-headers[^,]*//' \
     -e 's/libarts[0-9]*-dev/libarts-dev/' \
+    -e 's/libdvdread[0-9]*-dev/libdvdread2-dev/' \
+    -e 's/, libdvdplay0-dev[^,]*/, libdvdplay0-dev/' \
     -e 's/, libwx[^,]*//' \
     -e '/Package: wxvlc/,/^ *$/d' \
+    -e 's/, libflac-dev[^,]*//' \
+    -e 's/, libidl0[^,]*//' \
+    -e 's/, libglib2.0-0[^,]*//' \
+    -e 's/Section: gnome/Section: graphics/' \
+    -e 's/Section: kde/Section: graphics/' \
     < debian/control > debian/control.woody
 
 # rules: remove wxwindows stuff
@@ -32,6 +49,7 @@ sed -e 's/liba52-[^-]*-dev/a52dec-dev (>=0.7.3)/' \
 sed -e '/# Package: wxvlc/,/^ *$/d' \
     -e 's,^ARCH_EXCLUDE =,& -Nwxvlc,' \
     -e 's,--enable-wxwindows,--disable-wxwindows,' \
+    -e 's,--enable-flac,--disable-flac,' \
     -e 's, debian/changelog , debian/changelog.woody ,' \
     -e 's,dh_gencontrol[^#]*,& -- -ldebian/changelog.woody,' \
     < debian/rules > debian/rules.woody