]> git.sesse.net Git - bcachefs-tools-debian/blobdiff - default.nix
New upstream release
[bcachefs-tools-debian] / default.nix
index 48f2aa93bacabffcd38f70ad59fda0ce64391157..a693194ed1cb1752a0c2da1d2b8191138f2c0313 100644 (file)
@@ -1,6 +1,5 @@
 { lib
-, filter
-
+, doCheck ? true
 , stdenv
 , pkg-config
 , attr
@@ -20,8 +19,7 @@
 , docutils
 , nixosTests
 
-, lastModified
-, versionString ? lastModified
+, versionString ? "0.1"
 
 , inShell ? false
 , debugMode ? inShell
@@ -39,20 +37,8 @@ stdenv.mkDerivation {
 
        version = "v0.1-flake-${versionString}";
        VERSION = "v0.1-flake-${versionString}";
-       
-       src = filter.filter {
-               name = "bcachefs-tools";
-               root = ./.;
-               exclude = [
-                       ./rust-src
-                       
-                       ./.git
-                       ./nix
-                       
-                       ./flake.nix
-                       ./flake.lock
-               ];
-       };
+
+       src = (lib.cleanSource (builtins.path { name = "bcachefs-tools-src"; path = ./. ;} ));
 
        postPatch = "patchShebangs --build doc/macro2rst.py";
 
@@ -95,7 +81,7 @@ stdenv.mkDerivation {
                "INITRAMFS_DIR=${placeholder "out"}/etc/initramfs-tools"
        ];
 
-       doCheck = true; # needs bcachefs module loaded on builder
+       doCheck = doCheck; # needs bcachefs module loaded on builder
 
        checkInputs = [
                python39Packages.pytest
@@ -116,7 +102,7 @@ stdenv.mkDerivation {
                        rm tests/test_fuse.py
                '';
 
-       dontStrip = debugMode == true;
+       dontStrip = debugMode;
        passthru = {
                bcachefs_revision = let 
                        file = builtins.readFile ./.bcachefs_revision;