]> git.sesse.net Git - bcachefs-tools-debian/blobdiff - rust-src/mount/Cargo.toml
New upstream snapshot
[bcachefs-tools-debian] / rust-src / mount / Cargo.toml
similarity index 54%
rename from mount/Cargo.toml
rename to rust-src/mount/Cargo.toml
index 4fd0d497bdeeab204064d3da695a025ade0db368..d48d4f727d917b01350764f75ce9fa11e6e7c9d1 100644 (file)
@@ -1,34 +1,30 @@
 [package]
 name = "bcachefs-mount"
-version = "0.1.0"
-authors = ["Yuxuan Shui <yshuiv7@gmail.com>"]
+version = "0.3.1"
+authors = ["Yuxuan Shui <yshuiv7@gmail.com>", "Kayla Firestack <dev@kaylafire.me>"]
 edition = "2018"
 
 # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
 
 [dependencies]
-log = "0.4"
+tracing = "0.1.26"
+tracing-log = "0.1.2"
+tracing-subscriber = "0.2.20"
+tracing-attributes = "0.1.15"
 clap = { version = "2.33", features = [ "wrap_help" ] }
-env_logger = { version = "0.7", default-features = false }
 anyhow = "1.0"
-udev = "0.4"
-uuid = "0.8"
 libc = "0.2.69"
-gag = "0.1"
-bitfield = "0.13"
-memoffset = "0.5"
+uuid = "0.8"
+udev = "0.4"
+gag = "1.0.0"
 getset = "0.1"
 itertools = "0.9"
-structopt = "0.3"
+structopt = "0.3.23"
 parse-display = "0.1"
 errno = "0.2"
 either = "1.5"
 rpassword = "4"
+camino = "1.0.5"
+bch_bindgen = { path = "../bch_bindgen" }
 byteorder = "1.3"
 
-[lib]
-crate-type = ["staticlib"]
-
-[build-dependencies]
-pkg-config = "0.3"
-bindgen = { version = "0.53", default-features = false }