]> git.sesse.net Git - vlc/blobdiff - vlc.ebuild
* subsdec now uses the new options code.
[vlc] / vlc.ebuild
index c723df869695fed9abb6438def26a4fc93eaaba5..8c2db3ecc6d99344616cd6b785f0cf2d8ab9e0b6 100644 (file)
@@ -2,7 +2,7 @@
 # vlc.ebuild: A Gentoo ebuild for vlc
 ###############################################################################
 # Copyright (C) 2003 VideoLAN
-# $Id: vlc.ebuild,v 1.3 2003/05/21 19:55:25 hartman Exp $
+# $Id: vlc.ebuild,v 1.18 2003/07/21 01:38:37 hartman Exp $
 #
 # Authors: Derk-Jan Hartman <thedj at users.sf.net>
 #
 # along with this program; if not, write to the Free Software
 # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA  02111, USA.
 ###############################################################################
-IUSE="arts qt ncurses dvd gtk nls 3dfx esd kde X alsa ggi oggvorbis gnome xv oss sdl fbcon aalib avi slp truetype"
+# Instructions: http://wiki.videolan.org/index.php/Linux%20Gentoo
+# Some of the ideas in this ebuild are derived from the official Gentoo ebuild
+# Thanks to the Gentoo Team for supporting us.
+###############################################################################
+
+IUSE="arts ncurses dvd gtk nls 3dfx svga fbcon esd X alsa ggi oggvorbis gnome xv oss sdl fbcon aalib slp truetype v4l lirc wxwindows imlib matroska dvb pvr mozilla mad debug xvid"
 
 # Change these to correspond with the
 # unpacked dirnames of the CVS snapshots.
-PFFMPEG=ffmpeg-cvs-2003-05-17
-PLIBMPEG2=mpeg2dec-0.3.2-cvs
+PFFMPEG=ffmpeg-20030622
+PLIBMPEG2=mpeg2dec-20030612
 
 S=${WORKDIR}/${P}
 SFFMPEG=${WORKDIR}/${PFFMPEG}
 SLIBMPEG2=${WORKDIR}/${PLIBMPEG2}
 
-DESCRIPTION="VLC media player - A videoplayer that plays DVD,
-             VCD, files and networkstreams o.a."
+DESCRIPTION="VLC media player - Video player and streamer"
+SRC_URI="http://www.videolan.org/pub/${PN}/${PV}/${P}.tar.bz2
+                http://www.videolan.org/pub/${PN}/${PV}/contrib/mpeg2dec-20030612.tar.bz2
+                http://www.videolan.org/pub/${PN}/${PV}/contrib/ffmpeg-20030622.tar.bz2"
 
-# Use the correct CVS snapshot links. 
-SRC_URI="http://www.videolan.org/pub/testing/${P}/${P}.tar.bz2
-         http://www.videolan.org/pub/testing/contrib/ffmpeg-20030517.tar.bz2
-        http://www.videolan.org/pub/testing/contrib/mpeg2dec-20030418.tar.gz"
-
-#SRC_URI="http://www.videolan.org/pub/videolan/${PN}/${PV}/${P}.tar.bz2
-#               http://www.videolan.org/pub/videolan/${PN}/${PV}/contrib/libmpeg2.tar.gz
-#               http://www.videolan.org/pub/videolan/${PN}/${PV}/contrib/ffmpeg.tar.gz"
-HOMEPAGE="http://www.videolan.org"
+HOMEPAGE="http://www.videolan.org/vlc"
 
 SLOT="0"
 LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~amd64"
 
 DEPEND="X? ( virtual/x11 )
-       qt? ( x11-libs/qt )
+       aalib? ( >=media-libs/aalib-1.4_rc4-r2 )
+       alsa? ( >=media-libs/alsa-lib-0.9_rc2 )
+       dvb? ( media-libs/libdvb
+               media-tv/linuxtv-dvb )
        dvd? ( >=media-libs/libdvdread-0.9.3
                >=media-libs/libdvdcss-1.2.6
                >=media-libs/libdvdplay-1.0.1 )
-       sdl? ( >=media-libs/libsdl-1.2.5 )
        esd? ( >=media-sound/esound-0.2.22 )
        ggi? ( >=media-libs/libggi-2.0_beta3 )
-       gtk? ( =x11-libs/gtk+-1.2* )
-       kde? ( kde-base/kdelibs )
-       arts? ( kde-base/kdelibs )
        gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r1 )
+       gtk? ( =x11-libs/gtk+-1.2* )
+       imlib? ( >=media-libs/imlib2-1.0.6 )
+       lirc? ( app-misc/lirc )
+       mad? ( media-libs/libmad
+               media-libs/libid3tag )
+       matroska? ( media-libs/libmatroska )
+       mozilla? ( >=net-www/mozilla-1.4 )
        ncurses? ( sys-libs/ncurses )
-       oggvorbis? ( >=media-libs/libvorbis-1.0 
-                    >=media-libs/libogg-1.0 )
-       alsa? ( >=media-libs/alsa-lib-0.9_rc2 )
-       aalib? ( >=media-libs/aalib-1.4_rc4-r2 )
-       avi? ( >=media-libs/xvid-0.9.1 )
+       nls? ( sys-devel/gettext )
+       oggvorbis? ( >=media-libs/libvorbis-1.0
+               >=media-libs/libogg-1.0 )
+       sdl? ( >=media-libs/libsdl-1.2.5 )
        slp? ( >=net-libs/openslp-1.0.10 )
        truetype? ( >=media-libs/freetype-2.1.4 )
-       >=media-sound/mad-0.14.2b
-       >=media-libs/a52dec-0.7.4
+       wxwindows? ( >=x11-libs/wxGTK-2.4.1 )
+       xvid? ( >=media-libs/xvid-0.9.1 )
+       >=media-sound/lame-3.93.1
+       >=media-libs/libdvbpsi-0.1.2
        >=media-libs/faad2-1.1
-       >=media-libs/libdvbpsi-0.1.2"
-# other optional libraries
-#      >=media-libs/flac-1.1.0
-#      >=media-libs/libdv-0.98
-# wxwindows ought to be a USE variable, like all the others
-#      >=x11-libs/wxGTK-2.4.0
-
-# not in gentoo
+       >=media-libs/a52dec-0.7.4
+       >=media-libs/flac-1.1.0"
+
+# Missing support for
 #      tarkin
 #      theora
 #      tremor
 
-RDEPEND="nls? ( sys-devel/gettext )"
-
 # get kde and arts paths
 if [ -n "`use kde`" -o -n "`use arts`" ]; then
     inherit kde-functions
@@ -96,28 +96,29 @@ src_unpack() {
        
        unpack ${A}
        cd ${S}
+
        # if qt3 is installed, patch vlc to work with it instead of qt2
        ( use qt || use kde ) && ( \
        if [ ${QTDIR} = "/usr/qt/3" ]
        then
-               cp configure.ac configure.ac.orig
-               sed "s:-lkfile::" \
-                       configure.ac.orig > configure.ac
-               # adding configure.ac.in
-               cp configure.ac.in configure.ac.in.orig
-               sed "s:-lkfile::" \
-                       configure.ac.in.orig > configure.ac.in
+               cp configure configure.orig
+               sed -e "s:-lkfile::" configure.orig > configure
 
                cd ${S}/modules/gui/kde
                cp interface.h interface.h.orig
-               sed "s:\(#include <kmainwindow.h>\):\1\n#include <kstatusbar.h>:" \
+               sed -e "s:\(#include <kmainwindow.h>\):\1\n#include <kstatusbar.h>:" \
                        interface.h.orig > interface.h
 
                cp preferences.cpp preferences.cpp.orig
-               sed 's:\("vlc preferences", true, false, \)\("Save\):\1(KGuiItem)\2:' \
+               sed -e 's:\("vlc preferences", true, false, \)\("Save\):\1(KGuiItem)\2:' \
                        preferences.cpp.orig > preferences.cpp
        fi
        )
+
+       # Change the location of the glide headers
+       cd ${S}
+       cp configure configure.orig
+       sed -e "s:/usr/include/glide:/usr/include/glide3:" configure.orig > configure
        
        # patch libmpeg2
        cd ${SLIBMPEG2}
@@ -141,7 +142,7 @@ src_compile(){
        use mmx || myconf="--disable-mmx"
 
        ./configure ${myconf} \
-               --disable-mp3lame \
+               --enable-mp3lame \
                --disable-vorbis || die "./configure of ffmpeg failed"
        
        cd libavcodec
@@ -152,99 +153,87 @@ src_compile(){
        # Configure and build VLC
        cd ${S}
        myconf=""
-       
-       use X \
-               && myconf="${myconf} --enable-x11" \
-               || myconf="${myconf} --disable-x11"
-
-       use xv \
-               && myconf="${myconf} --enable-xvideo" \
-               || myconf="${myconf} --diable-xvideo"
-               
-       use qt \
-               && myconf="${myconf} --enable-qt" \
-               || myconf="${myconf} --disable-qt"
-       
+
+       use X || myconf="${myconf} --disable-x11"
+
+       use xv || myconf="${myconf} --disable-xvideo"
+
+       use ggi && myconf="${myconf} --enable-ggi"
+
+       use 3dfx && myconf="${myconf} --enable-glide"
+
+       use svga && myconf="${myconf} --enable-svgalib"
+
+       use sdl || myconf="${myconf} --disable-sdl"
+
+       use fbcon || myconf="${myconf} --disable-fb"
+
+       use aalib && myconf="${myconf} --enable-aa"
+
        use dvd \
-               && myconf="${myconf} \
-                       --enable-dvd \
-                       --enable-dvdread \
-                       --enable-vcd" \
+               && myconf="${myconf} --enable-dvdread" \
                || myconf="${myconf} \
                        --disable-dvd \
                        --disable-dvdread \
+                       --disable-dvdplay \
                        --disable-vcd"
-       
-       use esd \
-               && myconf="${myconf} --enable-esd" \
-               || myconf="${myconf} --disable-esd"
 
-       use ggi \
-               && myconf="${myconf} --enable-ggi" \
-               || myconf="${myconf} --disable-ggi"
-       
+       use alsa && myconf="${myconf} --enable-alsa"
+
+       use oss || myconf="${myconf} --disable-oss"
+
+       use esd && myconf="${myconf} --enable-esd"
+
+       use arts && myconf="${myconf} --enable-arts"
+
+       use nls || myconf="${myconf} --disable-nls"
+
        # the current gtk2 and gnome2 are prelimenary frameworks
        use gtk \
-               && myconf="${myconf} --enable-gtk --disable-gtk2" \
-               || myconf="${myconf} --disable-gtki --disable-gtk2"
+               && myconf="${myconf} --disable-gtk2" \
+               || myconf="${myconf} --disable-gtk --disable-gtk2"
 
-       use kde \
-               && myconf="${myconf} --enable-kde" \
-               || myconf="${myconf} --disable-kde"
+       use gnome && myconf="${myconf} --enable-gnome --disable-gnome2"
 
-       use nls \
-               || myconf="${myconf} --disable-nls"
-       
-       use 3dfx \
-               && myconf="${myconf} --enable-glide" \
-               || myconf="${myconf} --disable-glide"
+       use ncurses && myconf="${myconf} --enable-ncurses"
 
-       use arts \
-               && myconf="${myconf} --enable-arts" \
-               || myconf="${myconf} --disable-arts"
-       
-       use gnome \
-               && myconf="${myconf} --enable-gnome --disable-gnome2" \
-               || myconf="${myconf} --disable-gnome --disable-gnome2"
-       
-       use ncurses \
-               && myconf="${myconf} --enable-ncurses" \
-               || myconf="${myconf} --disable-ncurses"
-       
-       use oggvorbis \
-               && myconf="${myconf} --enable-vorbis --enable-ogg" \
-               || myconf="${myconf} --disable-vorbis --disable-ogg"
-
-       use alsa \
-               && myconf="${myconf} --enable-alsa" \
-               || myconf="${myconf} --disable-alsa"
-               
-       use oss \
-               && myconf="${myconf} --enable-oss" \
-               || myconf="${myconf} --disable-oss"
-
-       use sdl \
-               && myconf="${myconf} --enable-sdl" \
-               || myconf="${myconf} --disable-sdl"
-       
-       use fbcon \
-               && myconf="${myconf} --enable-fb" \
-               || myconf="${myconf} --disable-fb"
+       use oggvorbis || myconf="${myconf} --disable-vorbis --disable-ogg"
 
-       use aalib \
-               && myconf="${myconf} --enable-aa" \
-               || myconf="${myconf} --disable-aa"
+       use lirc && myconf="${myconf} --enable-lirc"
 
-       # there is no xvid USE variable
-       # it is pretty reasonable that users with the avi USE variable
-       # want xvid too cq. not.
-       use avi \
-               && myconf="${myconf} --enable-xvid" \
-               || myconf="${myconf} --disable-xvid"
+       use slp || myconf="${myconf} --disable-slp"
 
-       use slp \
-               && myconf="${myconf} --enable-slp" \
-               || myconf="${myconf} --disable-slp"
+       use mad || myconf="${myconf} --disable-mad"
+
+       # xvid is a local USE var, see /usr/portage/profiles/use.local.desc for more details
+       use xvid && myconf="${myconf} --enable-xvid"
+
+       use truetype || myconf="${myconf} --disable-freetype"
+
+       # v4l is a local USE var, see /usr/portage/profiles/use.local.desc for more details
+       use v4l && myconf="${myconf} --enable-v4l"
+
+       # If we use wxwindows and imlib, then we can also use skins
+       (use imlib && use wxwindows) && myconf="${myconf} --enable-skins"
+
+       # matroska is a local USE var. 
+       # http://forums.gentoo.org/viewtopic.php?t=63722&highlight=matroska
+       use matroska && myconf="${myconf} --enable-mkv"
+
+       use dvb && myconf="${myconf} --enable-satellite"
+
+       # pvr is a local USE var, see /usr/portage/profiles/use.local.desc for more details
+       use pvr && myconf="${myconf} --enable-pvr"
+
+       if [ "`use mozilla`" ]; then
+         myconf="${myconf} --enable-mozilla \
+           MOZILLA_CONFIG=/usr/lib/mozilla/mozilla-config \
+           XPIDL=/usr/bin/xpidl"
+       fi
+
+       use debug \
+               && myconf="${myconf} --enable-debug" \
+               || myconf="${myconf} --enable-release"
 
        # vlc uses its own ultraoptimizaed CXXFLAGS
        # and forcing custom ones generally fails building
@@ -253,20 +242,31 @@ src_compile(){
        export WANT_AUTOCONF_2_5=1
        export WANT_AUTOMAKE_1_6=1
 
-       econf \
-               --enable-ffmpeg --with-ffmpeg-tree=${SFFMPEG} \
+       # Avoid timestamp skews with autotools
+       touch configure.ac
+       touch aclocal.m4
+       touch configure
+       touch config.h.in
+       touch `find . -name Makefile.in`
+
+       myconf="${myconf} --enable-ffmpeg --with-ffmpeg-tree=${SFFMPEG} \
+               --with-ffmpeg-mp3lame \
                --enable-libmpeg2 --with-libmpeg2-tree=${SLIBMPEG2} \
-               --with-sdl \
-               --enable-release \
-               --enable-mad \
-               --enable-a52 \
                --enable-dvbpsi \
-               ${myconf} || die "configure of VLC failed"
+               --enable-faad \
+               --enable-flac \
+               --enable-a52 \
+               --disable-kde \
+               --disable-qt"
+
+       ewarn ${myconf}
+       econf ${myconf} || die "configure of VLC failed"
 
        # parallel make doesn't work with our complicated makefile
        # this is also the reason as why you shouldn't run autoconf
        # or automake yourself. (or bootstrap for that matter)
-       make || die "make of VLC failed"
+       MAKEOPTS="${MAKEOPTS} -j1
+       emake || die "make of VLC failed"
 }
 
 src_install() {
@@ -274,6 +274,6 @@ src_install() {
        einstall || die "make install failed"
 
        dodoc ABOUT-NLS AUTHORS COPYING ChangeLog HACKING INSTALL* \
-       MAINTAINERS NEWS README* MODULES THANKS
+       MAINTAINERS NEWS README* THANKS doc/ChangeLog-*
 
 }