]> git.sesse.net Git - vlc/blobdiff - vlc.ebuild
* modules/codec/ffmpeg/video.[ch]: another temporary workaround.
[vlc] / vlc.ebuild
index b23b2eb32bb543fb4ca9b0c6cd77176490649fb1..8c2db3ecc6d99344616cd6b785f0cf2d8ab9e0b6 100644 (file)
@@ -2,7 +2,7 @@
 # vlc.ebuild: A Gentoo ebuild for vlc
 ###############################################################################
 # Copyright (C) 2003 VideoLAN
-# $Id: vlc.ebuild,v 1.12 2003/07/10 00:47:42 hartman Exp $
+# $Id: vlc.ebuild,v 1.18 2003/07/21 01:38:37 hartman Exp $
 #
 # Authors: Derk-Jan Hartman <thedj at users.sf.net>
 #
@@ -25,7 +25,7 @@
 # Thanks to the Gentoo Team for supporting us.
 ###############################################################################
 
-IUSE="arts qt ncurses dvd gtk nls 3dfx matrox svga fbcon esd kde X alsa ggi oggvorbis gnome xv oss sdl fbcon aalib slp truetype v4l xvid lirc wxwindows imlib matroska dvb pvr"
+IUSE="arts ncurses dvd gtk nls 3dfx svga fbcon esd X alsa ggi oggvorbis gnome xv oss sdl fbcon aalib slp truetype v4l lirc wxwindows imlib matroska dvb pvr mozilla mad debug xvid"
 
 # Change these to correspond with the
 # unpacked dirnames of the CVS snapshots.
@@ -45,37 +45,37 @@ HOMEPAGE="http://www.videolan.org/vlc"
 
 SLOT="0"
 LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~amd64"
 
 DEPEND="X? ( virtual/x11 )
-       nls? ( sys-devel/gettext )
-       qt? ( x11-libs/qt )
+       aalib? ( >=media-libs/aalib-1.4_rc4-r2 )
+       alsa? ( >=media-libs/alsa-lib-0.9_rc2 )
+       dvb? ( media-libs/libdvb
+               media-tv/linuxtv-dvb )
        dvd? ( >=media-libs/libdvdread-0.9.3
                >=media-libs/libdvdcss-1.2.6
                >=media-libs/libdvdplay-1.0.1 )
-       sdl? ( >=media-libs/libsdl-1.2.5 )
        esd? ( >=media-sound/esound-0.2.22 )
        ggi? ( >=media-libs/libggi-2.0_beta3 )
-       gtk? ( =x11-libs/gtk+-1.2* )
-       kde? ( kde-base/kdelibs )
-       arts? ( kde-base/kdelibs )
        gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r1 )
+       gtk? ( =x11-libs/gtk+-1.2* )
+       imlib? ( >=media-libs/imlib2-1.0.6 )
+       lirc? ( app-misc/lirc )
+       mad? ( media-libs/libmad
+               media-libs/libid3tag )
+       matroska? ( media-libs/libmatroska )
+       mozilla? ( >=net-www/mozilla-1.4 )
        ncurses? ( sys-libs/ncurses )
-       oggvorbis? ( >=media-libs/libvorbis-1.0 
-                    >=media-libs/libogg-1.0 )
-       alsa? ( >=media-libs/alsa-lib-0.9_rc2 )
-       aalib? ( >=media-libs/aalib-1.4_rc4-r2 )
-       xvid? ( >=media-libs/xvid-0.9.1 )
+       nls? ( sys-devel/gettext )
+       oggvorbis? ( >=media-libs/libvorbis-1.0
+               >=media-libs/libogg-1.0 )
+       sdl? ( >=media-libs/libsdl-1.2.5 )
        slp? ( >=net-libs/openslp-1.0.10 )
        truetype? ( >=media-libs/freetype-2.1.4 )
-       lirc? ( app-misc/lirc )
-       imlib? ( >=media-libs/imlib2-1.0.6 )
-       wxwindows? ( >=x11-libs/wxGTK-2.4.0 )
-       matroska? ( media-libs/libmatroska )
-       dvb? ( media-libs/libdvb 
-               media-tv/linuxtv-dvb )
-        >=media-libs/libdvbpsi-0.1.2
-       >=media-sound/mad-0.14.2b
+       wxwindows? ( >=x11-libs/wxGTK-2.4.1 )
+       xvid? ( >=media-libs/xvid-0.9.1 )
+       >=media-sound/lame-3.93.1
+       >=media-libs/libdvbpsi-0.1.2
        >=media-libs/faad2-1.1
        >=media-libs/a52dec-0.7.4
        >=media-libs/flac-1.1.0"
@@ -142,7 +142,7 @@ src_compile(){
        use mmx || myconf="--disable-mmx"
 
        ./configure ${myconf} \
-               --disable-mp3lame \
+               --enable-mp3lame \
                --disable-vorbis || die "./configure of ffmpeg failed"
        
        cd libavcodec
@@ -160,17 +160,15 @@ src_compile(){
 
        use ggi && myconf="${myconf} --enable-ggi"
 
-        use 3dfx && myconf="${myconf} --enable-glide"
-
-        use matrox && myconf="${myconf} --enable-mga"
+       use 3dfx && myconf="${myconf} --enable-glide"
 
-        use svga && myconf="${myconf} --enable-svgalib"
+       use svga && myconf="${myconf} --enable-svgalib"
 
        use sdl || myconf="${myconf} --disable-sdl"
 
-        use fbcon || myconf="${myconf} --disable-fb"
+       use fbcon || myconf="${myconf} --disable-fb"
 
-        use aalib && myconf="${myconf} --enable-aa"
+       use aalib && myconf="${myconf} --enable-aa"
 
        use dvd \
                && myconf="${myconf} --enable-dvdread" \
@@ -182,7 +180,7 @@ src_compile(){
 
        use alsa && myconf="${myconf} --enable-alsa"
 
-        use oss || myconf="${myconf} --disable-oss"
+       use oss || myconf="${myconf} --disable-oss"
 
        use esd && myconf="${myconf} --enable-esd"
 
@@ -197,10 +195,6 @@ src_compile(){
 
        use gnome && myconf="${myconf} --enable-gnome --disable-gnome2"
 
-       use kde && myconf="${myconf} --enable-kde"
-
-       use qt && myconf="${myconf} --enable-qt"
-
        use ncurses && myconf="${myconf} --enable-ncurses"
 
        use oggvorbis || myconf="${myconf} --disable-vorbis --disable-ogg"
@@ -209,16 +203,17 @@ src_compile(){
 
        use slp || myconf="${myconf} --disable-slp"
 
-       use truetype && myconf="${myconf} --enable-freetype"
+       use mad || myconf="${myconf} --disable-mad"
 
        # xvid is a local USE var, see /usr/portage/profiles/use.local.desc for more details
        use xvid && myconf="${myconf} --enable-xvid"
 
+       use truetype || myconf="${myconf} --disable-freetype"
+
        # v4l is a local USE var, see /usr/portage/profiles/use.local.desc for more details
        use v4l && myconf="${myconf} --enable-v4l"
 
-       # wxwindows is a local USE var. already enabled by default, but depends on wxGTK
-       # but if we use wxwindows and imlib, then we can also use skins
+       # If we use wxwindows and imlib, then we can also use skins
        (use imlib && use wxwindows) && myconf="${myconf} --enable-skins"
 
        # matroska is a local USE var. 
@@ -228,7 +223,17 @@ src_compile(){
        use dvb && myconf="${myconf} --enable-satellite"
 
        # pvr is a local USE var, see /usr/portage/profiles/use.local.desc for more details
-        use pvr && myconf="${myconf} --enable-pvr"
+       use pvr && myconf="${myconf} --enable-pvr"
+
+       if [ "`use mozilla`" ]; then
+         myconf="${myconf} --enable-mozilla \
+           MOZILLA_CONFIG=/usr/lib/mozilla/mozilla-config \
+           XPIDL=/usr/bin/xpidl"
+       fi
+
+       use debug \
+               && myconf="${myconf} --enable-debug" \
+               || myconf="${myconf} --enable-release"
 
        # vlc uses its own ultraoptimizaed CXXFLAGS
        # and forcing custom ones generally fails building
@@ -245,13 +250,14 @@ src_compile(){
        touch `find . -name Makefile.in`
 
        myconf="${myconf} --enable-ffmpeg --with-ffmpeg-tree=${SFFMPEG} \
+               --with-ffmpeg-mp3lame \
                --enable-libmpeg2 --with-libmpeg2-tree=${SLIBMPEG2} \
                --enable-dvbpsi \
-               --enable-release \
-               --enable-mad \
                --enable-faad \
                --enable-flac \
-               --enable-a52"
+               --enable-a52 \
+               --disable-kde \
+               --disable-qt"
 
        ewarn ${myconf}
        econf ${myconf} || die "configure of VLC failed"
@@ -259,7 +265,8 @@ src_compile(){
        # parallel make doesn't work with our complicated makefile
        # this is also the reason as why you shouldn't run autoconf
        # or automake yourself. (or bootstrap for that matter)
-       make || die "make of VLC failed"
+       MAKEOPTS="${MAKEOPTS} -j1
+       emake || die "make of VLC failed"
 }
 
 src_install() {
@@ -267,6 +274,6 @@ src_install() {
        einstall || die "make install failed"
 
        dodoc ABOUT-NLS AUTHORS COPYING ChangeLog HACKING INSTALL* \
-       MAINTAINERS NEWS README* MODULES THANKS doc/ChangeLog-*
+       MAINTAINERS NEWS README* THANKS doc/ChangeLog-*
 
 }