]> git.sesse.net Git - vlc/blobdiff - vlc.spec
* configure.ac.in: removed the -fno-exceptions gcc option from the compilation of...
[vlc] / vlc.spec
index f26b12cce75857e5bcdbb23b7046db020b577f7f..0fa15e8fe77bc0db46e1a918020ffa7898969959 100644 (file)
--- a/vlc.spec
+++ b/vlc.spec
@@ -1,5 +1,5 @@
 %define name           vlc
-%define version        0.5.0
+%define version        0.5.2
 %define rel            1
 
 %define        libmajor        0
@@ -16,7 +16,7 @@
 
 %define with_dvdplay 1
 
-%define with_mozilla 0
+%define with_mozilla 1
 %define with_gtk 1
 %define with_gnome 1
 %define with_qt 0
 
 %define with_slp 1
 
-%define        buildfor_rh80   0
-%define        buildfor_mdk82  0
-%define        buildfor_mdk90  0
+## but we try to figure out on wich system we are building
+%define        buildfor_mdk82  %([[ -e /etc/mandrake-release ]] && awk '{print ($4 == "8.2")}' %{_sysconfdir}/mandrake-release || echo 0)
+%define        buildfor_mdk90  %([[ -e /etc/mandrake-release ]] && awk '{print ($4 == "9.0")}' %{_sysconfdir}/mandrake-release || echo 0)
+%define        buildfor_mdk91  %([[ -e /etc/mandrake-release ]] && awk '{print ($4 == "9.1")}' %{_sysconfdir}/mandrake-release || echo 0)
+# not a mandrake one.
+%define buildfor_rh80 %([[ -e /etc/mandrake-release ]] && echo 0 || echo 1)
 
 # new macros
 %if %buildfor_mdk82 || %buildfor_mdk90 || %buildfor_rh80
 %define configure2_5x CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=/usr
 %define make %__make
 %define makeinstall_std %__make DESTDIR="$RPM_BUILD_ROOT" install
+%define _menudir /usr/lib/menu
+%define _iconsdir /usr/share/icons
+%define _liconsdir /usr/share/icons/large
+%define _miconsdir /usr/share/icons/mini
 # adjust define for Redhat.
+%define with_ggi 0
+%define with_dvb 0
+%define with_slp 0
+%define with_mozilla 0
 %endif
 
 # without
 
 %{?_with_slp:          %{expand: %%define with_slp 1}}
 
-Summary:       VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
+Summary:       VLC is a free MPEG, MPEG2, DVD and DivX player.
 Name:          %{name}
 Version:       %{version}
 Release:       %{release}
@@ -142,6 +153,8 @@ Requires:   vlc-plugin-a52
 
 BuildRoot:     %_tmppath/%name-%version-%release-root
 
+# for redhat system, NO buildrequires. rh sux
+%if !%buildfor_rh80
 %if %with_mozilla
 Buildrequires: mozilla-devel
 %endif
@@ -162,7 +175,6 @@ Buildrequires:      libncurses5-devel
 %if %with_wx
 Buildrequires: wxGTK-devel
 %endif
-%endif
 %if %with_lirc
 Buildrequires: liblirc-devel
 %endif
@@ -199,6 +211,12 @@ Buildrequires:     liba52dec-devel
 %if %with_ffmpeg
 Buildrequires: libffmpeg-devel
 %endif
+%if %with_dvdplay
+BuildRequires: libdvdplay-devel
+%endif
+%if %with_dvb
+BuildRequires: libdvbpsi-devel
+%endif
 
 %if %with_alsa
 Buildrequires: libalsa2-devel
@@ -214,15 +232,16 @@ Buildrequires:    libarts-devel
 Buildrequires: libopenslp-devel
 %endif
 
+%endif #no buildrequires for rh systems.
 
 %description
 VideoLAN is an OpenSource streaming solution for every OS developed by
 students from the Ecole Centrale Paris and developers from all over the
 World.
-The VideoLAN Client (vlc) plays MPEG1, MPEG2 and MPEG4 (aka DivX) files,
-DVDs, VCDs, SVCDs, from a satellite card, from an MPEG2 Transport
-Streams sent by the VideoLAN Server (vls) or from a Web server (with the
-HTTP input).
+VLC (VideoLAN Client) is a media player that can play MPEG1, MPEG2 and
+MPEG4 (aka DivX) files, DVDs, VCDs, SVCDs, from a satellite card, from
+a stream sent by VLS (VideoLAN Server), from another VLC, or from a Web
+server.
 You may install vlc-gnome or vlc-gtk to have a nice graphical interface.
 This package contains no CSS unscrambling functionality for DVDs ;
 you need the libdvdcss library available from 
@@ -230,22 +249,22 @@ http://www.videolan.org/libdvdcss/ or http://plf.zarb.org/
 
 #general packages
 %package -n %libname-devel
-Summary: Development files for the VideoLAN Client
+Summary: Development files for the VLC media player
 Group: Development/C
 Requires: %name = %version-%release
 Provides: %name-devel = %version-%release
 Provides: lib%name-devel = %version-%release
 %description -n %libname-devel
-Development files for the VideoLAN Client
-VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
-
+Development files for the VLC media player
 This package contains headers and a static library required to build plugins
-for the VideoLAN Client, or standalone applications using VideoLAN Client.
+for the VLC media player, or standalone applications using features from VLC.
 
 %package -n mozilla-plugin-vlc
 Summary: A multimedia plugin for Mozilla, based on vlc
 group: Video
 Requires: %name = %version-%release
+%{expand: %%define mozve %(rpm -q mozilla| sed 's/mozilla-\([0-9].*\)-.*$/\1/')}
+Requires: mozilla = %mozve
 %description -n mozilla-plugin-vlc
 This plugin adds support for MPEG, MPEG2, DVD and DivX to your Mozilla
 browser. The decoding process is done by vlc and the output window is
@@ -255,137 +274,115 @@ support for fullscreen display.
 
 # intf plugins
 %package -n gvlc
-Summary: Gtk plugin for the VideoLAN client
+Summary: Gtk plugin for the VLC media player
 Group: Video
 Requires: %{name} = %{version}
 Provides: vlc-gui
 %description -n gvlc
-VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
-
-This plugin adds a Gtk+ interface to vlc, the VideoLAN Client. To
+This plugin adds a Gtk+ interface to the VLC media player. To
 activate it, use the `--intf gtk' flag or run the `gvlc' program.
 
 %package -n gnome-vlc
-Summary: Gnome plugin for the VideoLAN client
+Summary: Gnome plugin for the VLC media player
 Group: Video
 Requires: %{name} = %{version}
 Provides: vlc-gui, vlc-gnome
 Obsoletes: vlc-gnome
 %description -n gnome-vlc
-VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
-
-This plugin adds a Gnome interface to vlc, the VideoLAN Client. To
+This plugin adds a Gnome interface to the VLC media player. To
 activate it, use the `--intf gnome' flag or run the `gnome-vlc' program.
 
 %package -n qvlc
-Summary: Qt2 plugin for the VideoLAN client
+Summary: Qt2 plugin for the VLC media player
 Group: Video
 Requires: %{name} = %{version}
 Provides: vlc-gui, vlc-qt
 Obsoletes: vlc-qt
 %description -n qvlc
-VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
-
-This plugin adds a Qt interface to vlc, the VideoLAN Client. To
-activate it, use the `--intf qt' flag or run the `qvlc' program.
+This plugin adds a Qt interface to the VLC media player. To activate it,
+use the `--intf qt' flag or run the `qvlc' program.
 
 %package -n kvlc
-Summary: KDE frontend for the VideoLAN client
+Summary: KDE frontend for the VLC media player
 Group: Video
 Requires: %{name} = %{version}
 Provides: vlc-gui
 %description -n kvlc
-VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
-
-This plugin adds a KDE interface to vlc, the VideoLAN Client. To
+This plugin adds a KDE interface to the VLC media player. To
 activate it, use the `--intf kde' flag or run the `kvlc' program.
 
 %package plugin-ncurses
-Summary: Ncurses console-based plugin for the VideoLAN client
+Summary: Ncurses console-based plugin for the VLC media player
 Group: Video
 Requires: %{name} = %{version}
 %description plugin-ncurses
-VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
-
-This plugin adds a ncurses interface to vlc, the VideoLAN Client. To
+This plugin adds a ncurses interface to the VLC media player. To
 activate it, use the `--intf ncurses' flag.
 
 %package plugin-lirc
-Summary: Lirc plugin for the VideoLAN client
+Summary: Lirc plugin for the VLC media player
 Group: Video
 Requires: %{name} = %{version}
 Obsoletes: vlc-lirc
 Provides: vlc-lirc
 %description plugin-lirc
-VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
-
-This plugin is an infrared lirc interface for vlc, the
-VideoLAN Client. To activate it, use the `--intf lirc' flag.
+This plugin is an infrared lirc interface for the VLC media player. To
+activate it, use the `--extraintf lirc' flag.
 
 %package -n wxvlc
-Summary: WxWindow plugin for the VideoLAN client
+Summary: WxWindow plugin for the VLC media player
 Group: Video
 Requires: %{name} = %{version}
 Obsoletes: vlc-lirc
 Provides: vlc-lirc
 %description -n wxvlc
-VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
-
-This plugin adds a wxWindow interface to vlc, the VideoLAN Client. To
+This plugin adds a wxWindow interface to the VLC media player. To
 activate it, use the `--intf wxwin' flag or run the `wxvlc' program.
 
 
 #
 # video plugins
 %package plugin-aa
-Summary: ASCII art video plugin for the VideoLAN client
+Summary: ASCII art video plugin for the VLC media player
 Group: Video
 Requires: %{name} = %{version}
 Obsoletes: vlc-aa
 Provides: vlc-aa
 %description plugin-aa
-VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
-
-This is an ASCII art video output plugin for vlc, the VideoLAN
-Client. To activate it, use the `--vout aa' flag or select the `aa'
-vout plugin from the preferences menu.
+This is an ASCII art video output plugin for the VLC media playe. To
+activate it, use the `--vout aa' flag or select the `aa' video output
+plugin from the preferences menu.
 
 
 %package plugin-sdl
-Summary: Simple DirectMedia Layer video plugin for the VideoLAN client
+Summary: Simple DirectMedia Layer video plugin for the VLC media player
 Group: Video
 Requires: %{name} = %{version}
 Obsoletes: vlc-sdl
 Provides: vlc-sdl
 %description plugin-sdl
-VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
-
 This plugin adds support for the Simple DirectMedia Layer library to
-vlc, the VideoLAN Client. To activate it, use the `--vout sdl' or
-`--aout sdl' flags or select the `sdl' vout or aout plugin from the
-preferences menu.
+the VLC media player. To activate it, use the `--vout sdl' or
+`--aout sdl' flags or select the `sdl' video or audio output plugin
+from the preferences menu.
 
 %package plugin-ggi
-Summary: GGI video plugin for the VideoLAN client
+Summary: GGI video plugin for the VLC media player
 Group: Video
 Requires: %{name} = %{version}
 Obsoletes: vlc-ggi
 Provides: vlc-ggi
 %description plugin-ggi
-VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
-
-This is a GGI plugin for vlc, the VideoLAN Client.  To activate it, use
-the `--vout ggi' flag or select the `ggi' vout plugin from the preferences
-menu.
+This is a GGI plugin for the VLC media player. To activate it, use
+the `--vout ggi' flag or select the `ggi' video output plugin from
+the preferences menu.
 
 %package plugin-svgalib
-Summary: SVGAlib video plugin for the VideoLAN client
+Summary: SVGAlib video plugin for the VLC media player
 Group: Video
 Requires: %{name} = %{version}
 %description plugin-svgalib
-VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
-
-This plugin adds support for SVGAlib to vlc, the VideoLAN Client. To
+This plugin adds support for SVGAlib to the VLC media player. To
 activate it, use the `--vout svgalib' flag or select the `svgalib' video
 output plugin from the preferences menu. Note that you will need root
 permissions to use SVGAlib.
@@ -394,124 +391,104 @@ permissions to use SVGAlib.
 #
 # visualization plugins
 %package plugin-xosd
-Summary: X On-Screen Display plugin for the VideoLAN client
+Summary: X On-Screen Display plugin for the VLC media player
 Group: Video
 Requires: %{name} = %{version}
 %description plugin-xosd
-VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
-
-This is an On-Screen Display plugin for vlc, the VideoLAN Client. To
-activate it, use the `--intf xosd' flag or select the `xosd' interface
-plugin from the preferences menu.
+This is an On-Screen Display plugin for the VLC media player. To activate
+it, use the `--extraintf xosd' flag or select the `xosd' interface plugin
+from the preferences menu.
 
 # codec plugins
 %package plugin-mad
-Summary: MAD audio codec plugin for the VideoLAN client
+Summary: MAD audio codec plugin for the VLC media player
 Group: Video
 Requires: %{name} = %{version}
 Obsoletes: vlc-mad
 Provides: vlc-mad
 %description plugin-mad
-VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
-
 This plugin adds support for libmad, the MPEG audio decoder library,
-to the VideoLAN Client. MAD is 100% fixed-point based. To activate
+to the VLC media player. MAD is 100% fixed-point based. To activate
 this plugin, use the `--mpeg_adec mad' flag or select the `mad' MPEG
 decoder from the preferences menu.
 
 %package plugin-ogg
-Summary: Ogg demuxer and Vorbis codec plugin for the VideoLAN client
+Summary: Ogg demuxer and Vorbis codec plugin for the VLC media player
 Group: Video
 Requires: %{name} = %{version}
 %description plugin-ogg
-VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
-
 These plugins add support for the Ogg bitstream format and the Ogg Vorbis
-compressed audio format to vlc, the VideoLAN Client. They are autodetected.
+compressed audio format to the VLC media player. They are autodetected.
 
 %package plugin-a52
-Summary: A-52 (AC-3) codec plugin for the VideoLAN client
+Summary: A-52 (AC-3) codec plugin for the VLC media player
 Group: Video
 Requires: %{name} = %{version}
 %description plugin-a52
-VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
-
 This plugin adds support for the ATSC A-52 (aka. AC-3) audio format to
-vlc, the VideoLAN Client. The plugin is autodetected.
+the VLC media player. The plugin is autodetected.
 
 %package plugin-dv
-Summary: DV codec plugin for the VideoLAN client
+Summary: DV codec plugin for the VLC media player
 Group: Video
 Requires: %{name} = %{version}
 %description plugin-dv
-VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
-
-This plugin adds support for the DV video format to vlc, the VideoLAN
-Client. The plugin is autodetected.
+This plugin adds support for the DV video format to the VLC media player.
+The plugin is autodetected.
 
 #
 # input plugins
 %package plugin-dvb
-Summary: DVB input plugin for the VideoLAN client
+Summary: DVB input plugin for the VLC media player
 Group: Video
 Requires: %{name} = %{version}
 %description plugin-dvb
-VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
-
-This plugin adds support for DVB cards to vlc, the VideoLAN Client. Note
+This plugin adds support for DVB cards to the VLC media player. Note
 that your card needs to be supported by your kernel before vlc can use it.
 
 #
 # audio plugins
 %package plugin-esd
-Summary: Enlightened Sound Daemon audio plugin for the VideoLAN client
+Summary: Enlightened Sound Daemon audio plugin for the VLC media player
 Group: Video
 Requires: %{name} = %{version}
 Obsoletes: vlc-esd
 Provides: vlc-esd
 %description plugin-esd
-VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
-
-This plugin adds support for the Enlightened Sound Daemon to vlc, the
-VideoLAN Client. To activate it, use the `--aout esd' flag or select
-the `esd' aout plugin from the preferences menu.
+This plugin adds support for the Enlightened Sound Daemon to the VLC
+media player. To activate it, use the `--aout esd' flag or select the
+`esd' audio output plugin from the preferences menu.
 
 %package plugin-arts
-Summary: aRts audio plugin for the VideoLAN client
+Summary: aRts audio plugin for the VLC media player
 Group: Video
 Requires: %{name} = %{version}
 Obsoletes: vlc-arts
 Provides: vlc-arts
 %description plugin-arts
-VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
-
-This plugin adds support for the aRts Sound System to vlc, the
-VideoLAN Client. To activate it, use the `--aout arts' flag or
-select the `arts' aout plugin from the preferences menu.
+This plugin adds support for the aRts Sound System to the VLC media
+player. To activate it, use the `--aout arts' flag or select the `arts'
+audio output plugin from the preferences menu.
 
 %package plugin-alsa
-Summary: Advanced Linux Sound Architecture audio plugin for the VideoLAN client
+Summary: Advanced Linux Sound Architecture audio plugin for the VLC media player
 Group: Video
 Requires: %{name} = %{version}
 Obsoletes: vlc-alsa
 Provides: vlc-alsa
 %description plugin-alsa
-VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
-
 This plugin adds support for the Advanced Linux Sound Architecture to
-vlc, the VideoLAN Client. To activate it, use the `--aout alsa' flag or
-select the `alsa' aout plugin from the preferences menu.
+the VLC media player. To activate it, use the `--aout alsa' flag or
+select the `alsa' audio output plugin from the preferences menu.
 
 
 %package plugin-slp
-Summary: Service Location Protocol acces plugin for the VideoLAN client
+Summary: Service Location Protocol acces plugin for the VLC media player
 Group: Video
 Requires: %{name} = %{version}
 %description plugin-slp
-VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
-
 This plugin adds support for the Service Location Protocol to
-vlc, the VideoLAN Client.
+the VLC media player.
 
 
 %prep
@@ -525,7 +502,11 @@ vlc, the VideoLAN Client.
 # yves 0.4.0-1mdk
 # ffmpeg: static linking cause no official ffmpeg release with a stable ABI
 # ffmpeg:no plugin posible on ia64 due to the static linking (can not put .a in a .so)
-
+%if %with_mozilla
+%define moz_ver 1.3a
+export XPIDL=/usr/lib/mozilla-%moz_ver/xpidl
+perl -pi -e  's#-I/usr/share/idl/mozilla#-I/usr/share/idl/mozilla-1.3a#' Makefile.in
+%endif
 export QTDIR=%{_libdir}/qt3
 # mandrake kernel specific
 export CPPFLAGS="${CPPFLAGS:--I/usr/src/linux/3rdparty/mod_dvb/include}"
@@ -626,7 +607,7 @@ export CPPFLAGS="${CPPFLAGS:--I/usr/src/linux/3rdparty/mod_dvb/include}"
 %make
 
 %install
-rm -f %buildroot
+rm -fr %buildroot
 %makeinstall_std
 %find_lang %name
 install -d %buildroot/%_mandir/man1
@@ -636,30 +617,30 @@ install doc/vlc-config.1 %buildroot/%_mandir/man1
 # menu
 mkdir -p %buildroot/%_menudir
 cat > %buildroot/%_menudir/vlc << EOF
-?package(vlc): command="%_bindir/vlc" hotkey="V" needs="X11" longtitle="VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution" section="Multimedia/Video" title="VideoLAN Client" icon="vlc.png" hints="Video"
+?package(vlc): command="%_bindir/vlc" hotkey="V" needs="X11" longtitle="VLC is a free MPEG, MPEG2, DVD and DivX player" section="Multimedia/Video" title="VLC media player" icon="vlc.png" hints="Video"
 EOF
 %if %with_gtk
 cat > %buildroot/%_menudir/gvlc << EOF
-?package(gvlc): command="%_bindir/gvlc" needs="X11" longtitle="VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution" section="Multimedia/Video" title="Gtk VideoLAN Client" icon="gvlc.png" hints="Video"
+?package(gvlc): command="%_bindir/gvlc" needs="X11" longtitle="VLC is a free MPEG, MPEG2, DVD and DivX player" section="Multimedia/Video" title="VLC Gtk media player" icon="gvlc.png" hints="Video"
 EOF
 %endif
 %if %with_gnome
 cat > %buildroot/%_menudir/gnome-vlc << EOF
-?package(gnome-vlc): command="%_bindir/gnome-vlc" needs="X11" longtitle="VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution" section="Multimedia/Video" title="Gnome VideoLAN Client" icon="gnome-vlc.png" hints="Video"
+?package(gnome-vlc): command="%_bindir/gnome-vlc" needs="X11" longtitle="VLC is a free MPEG, MPEG2, DVD and DivX player" section="Multimedia/Video" title="VLC Gnome media player" icon="gnome-vlc.png" hints="Video"
 EOF
 %endif
 %if %with_qt
 cat > %buildroot/%_menudir/qvlc << EOF
-?package(qvlc): command="%_bindir/qvlc" needs="X11" longtitle="VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution" section="Multimedia/Video" title="Qt VideoLAN Client" icon="qvlc.png" hints="Video"
+?package(qvlc): command="%_bindir/qvlc" needs="X11" longtitle="VLC is a free MPEG, MPEG2, DVD and DivX player" section="Multimedia/Video" title="VLC Qt media player" icon="qvlc.png" hints="Video"
 EOF
 %endif
 %if %with_kde
 cat > %buildroot/%_menudir/kvlc << EOF
-?package(kvlc): command="%_bindir/kvlc" needs="X11" longtitle="VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution" section="Multimedia/Video" title="KDE VideoLAN Client" icon="kvlc.png" hints="Video"
+?package(kvlc): command="%_bindir/kvlc" needs="X11" longtitle="VLC is a free MPEG, MPEG2, DVD and DivX player" section="Multimedia/Video" title="VLC KDE media player" icon="kvlc.png" hints="Video"
 EOF
 %endif
 %if %with_wx
-?package(wxvlc): command="%_bindir/wxvlc" needs="X11" longtitle="VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution" section="Multimedia/Video" title="wxWindow VideoLAN Client" icon="vlc.png" hints="Video"
+?package(wxvlc): command="%_bindir/wxvlc" needs="X11" longtitle="VLC is a free MPEG, MPEG2, DVD and DivX player" section="Multimedia/Video" title="VLC wxWindow media player" icon="vlc.png" hints="Video"
 %endif
 
 # icons
@@ -691,11 +672,17 @@ install -m 644 %pngdir/qvlc48x48.png %buildroot/%_liconsdir/qvlc.png
 
 #rpm (>= 4.0.4-20mdk) now checks for installed (but unpackaged) files
 rm -f %pngdir/*
+%if %buildfor_rh80
+rm -fr %buildroot/%_menudir
+rm -fr %buildroot/%_iconsdir
+%endif
 
+%if !%buildfor_rh80
 %post
 %update_menus
 %postun
 %clean_menus
+%endif
 
 %clean
 rm -fr %buildroot
@@ -861,10 +848,12 @@ rm -fr %buildroot
 %dir %_libdir/vlc/visualization
 
 %_mandir/man1/vlc.*
+%if !%buildfor_rh80
 %_menudir/vlc
 %_miconsdir/vlc.png
 %_iconsdir/vlc.png
 %_liconsdir/vlc.png
+%endif
 
 %files -n %libname-devel
 %defattr(-,root,root)
@@ -880,9 +869,7 @@ rm -fr %buildroot
 %files -n mozilla-plugin-vlc
 %defattr(-,root,root)
 %doc README
-# FIXME: seems to be mozilla-version/plugin on Mandrake
-#%dir %_libdir/mozilla
-%_libdir/mozilla*/*
+%_libdir/mozilla/*/*
 %endif
 
 # intf plugins
@@ -893,6 +880,7 @@ rm -fr %buildroot
 %_libdir/vlc/misc/libgtk_main_plugin.so
 %_libdir/vlc/gui/libgtk_plugin.so
 %_bindir/gvlc
+%if !%buildfor_rh80
 %_menudir/gvlc
 %_miconsdir/gvlc.png
 %_iconsdir/gvlc.png
@@ -902,6 +890,7 @@ rm -fr %buildroot
 %postun -n gvlc
 %clean_menus
 %endif
+%endif
 
 %if %with_gnome
 %files -n gnome-vlc
@@ -910,6 +899,7 @@ rm -fr %buildroot
 %_libdir/vlc/misc/libgnome_main_plugin.so
 %_libdir/vlc/gui/libgnome_plugin.so
 %_bindir/gnome-vlc
+%if !%buildfor_rh80
 %_menudir/gnome-vlc
 %_miconsdir/gnome-vlc.png
 %_iconsdir/gnome-vlc.png
@@ -919,6 +909,7 @@ rm -fr %buildroot
 %postun -n gnome-vlc
 %clean_menus
 %endif
+%endif
 
 %if %with_qt
 %files -n qvlc
@@ -926,6 +917,7 @@ rm -fr %buildroot
 %doc README
 %_libdir/vlc/gui/libqt_plugin.so
 %_bindir/qvlc
+%if !%buildfor_rh80
 %_menudir/qvlc
 %_miconsdir/qvlc.png
 %_iconsdir/qvlc.png
@@ -935,12 +927,14 @@ rm -fr %buildroot
 %postun -n qvlc
 %clean_menus
 %endif
+%endif
 
 %if %with_kde
 %files -n kvlc
 %doc README
 %_libdir/vlc/gui/libkde_plugin.so
 %_bindir/kvlc
+%if !%buildfor_rh80
 %_menudir/kvlc
 %_miconsdir/kvlc.png
 %_iconsdir/kvlc.png
@@ -950,6 +944,7 @@ rm -fr %buildroot
 %postun -n kvlc
 %clean_menus
 %endif
+%endif
 
 %if %with_ncurses
 %files plugin-ncurses