]> git.sesse.net Git - vlc/blobdiff - vlc.spec
* TODO: put todo's in TODO list instead of commit messages :)
[vlc] / vlc.spec
index 1a2c9f8c67e91365e91166ac5df52c6ce73d24da..28dfd61baf992fa50231703de94d8ff480db9b99 100644 (file)
--- a/vlc.spec
+++ b/vlc.spec
@@ -1,13 +1,13 @@
 %define mozver 1.4.1
 
-Summary: The VideoLAN client, also a very good standalone video player.
+Summary: VLC media player, a multimedia player and streaming application.
 Name: vlc
 Version: 0.7.0
-Release: test1
+Release: 1
 Group: Applications/Multimedia
 License: GPL
 URL: http://www.videolan.org/
-Source: http://www.videolan.org/pub/videolan/vlc/vlc-%{version}-%{release}.tar.bz2
+Source: http://download.videolan.org/pub/videolan/vlc/vlc-%{version}-%{release}.tar.bz2
 Buildroot: %{_tmppath}/%{name}-root
 Packager: Jason Luka <jason@geshp.com>
 Buildrequires: XFree86-devel, desktop-file-utils, libpostproc >= 1.0
@@ -42,6 +42,8 @@ Buildrequires: XFree86-devel, desktop-file-utils, libpostproc >= 1.0
 %{!?_without_mozilla:BuildRequires: mozplugger >= 1.3.2}
 %{!?_without_speex:BuildRequires: speex-devel >= 1.0.3}
 %{!?_without_aa:BuildRequires: aalib >= 1.4}
+%{!?_without_mkv:BuildRequires: matroska}
+%{!?_without_fribidi:BuildRequires: fribidi-devel}
 
 Obsoletes: videolan-client
 
@@ -73,32 +75,36 @@ Requires: XFree86, desktop-file-utils
 %{!?_without_mozilla:Requires: mozilla >= %{mozver}}
 %{!?_without_speex:Requires: speex >= 1.0.3}
 %{!?_without_wxwindows:Requires: wxGTK >= 2.4.2}
+%{!?_without_mkv:Requires: matroska}
+%{!?_without_fribidi:Requires: fribidi}
 
 %description
-VideoLAN Client (VLC) is a highly portable multimedia player for various
-audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX, mp3, ogg, ...) as
-well as DVDs, VCDs, and various streaming protocols.
+VLC media player is a highly portable multimedia player for various audio and 
+video formats (MPEG-1, MPEG-2, MPEG-4, DivX, mp3, ogg, ...) as well as DVD's, 
+VCD's, and various streaming protocols. It can also be used as a server to 
+stream in unicast or multicast in IPv4 or IPv6 on a high-bandwidth network.
 
 Available rpmbuild rebuild options :
 --without dvd dvdread dvdplay dvbpsi dv v4l avi asf aac ogg rawdv mad ffmpeg xvid
           mp4 a52 vorbis mpeg2dec flac aa esd arts alsa gtk gnome xosd lsp lirc
-          pth id3tag dv qt kde ncurses faad wxwindows
+          pth id3tag dv qt kde ncurses faad wxwindows mkv fribidi
 
 Options that would need not yet existing add-on packages :
 --with tremor tarkin theora ggi glide svgalib mga
 
 
 %package devel
-Summary: Header files and static library from the Videolan Client.
+Summary: Header files and static library from VLC media player.
 Group: Development/Libraries
 Requires: %{name} = %{version}
 
 %description devel
-VideoLAN Client (VLC) is a highly portable multimedia player for various
-audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX, mp3, ogg, ...) as
-well as DVDs, VCDs, and various streaming protocols.
+VLC media player is a highly portable multimedia player for various audio and 
+video formats (MPEG-1, MPEG-2, MPEG-4, DivX, mp3, ogg, ...) as well as DVD's, 
+VCD's, and various streaming protocols. It can also be used as a server to 
+stream in unicast or multicast in IPv4 or IPv6 on a high-bandwidth network.
 
-Install this package if you need to build Videolan Client plugins or intend
+Install this package if you need to build VLC media player plugins or intend
 to link statically to it.
 
 
@@ -156,7 +162,8 @@ ln /usr/share/idl/mozilla-%{mozver} /usr/share/idl/mozilla -sf
        %{!?_without_esd:--enable-esd} \
        %{!?_without_arts:--enable-arts} \
        %{?_with_alsa:--enable-alsa} \
-       --disable-waveout \
+       %{!?_without_fribidi:--enable-fribidi} \
+        --disable-waveout \
        %{!?_without_gtk:--enable-gtk} \
        --disable-familiar \
        %{!?_without_gnome:--enable-gnome} \
@@ -176,7 +183,9 @@ ln /usr/share/idl/mozilla-%{mozver} /usr/share/idl/mozilla -sf
        %{!?_without_mozilla:--enable-mozilla} \
         %{?_without_speex:--disable-speex} \
        --disable-testsuite \
-       --enable-plugins
+       --enable-plugins \
+        %{?_without_mkv:--disable-mkv} \
+        %{!?_without_fribidi:--enable-fribidi}
 make %{?_smp_mflags}
 
 %install
@@ -187,7 +196,7 @@ find  %{buildroot}%{_libdir}/vlc -name "*.so" | xargs strip
 
 cat > %{name}.desktop << EOF
 [Desktop Entry]
-Name=VideoLAN Media Player
+Name=VLC Media Player
 Comment=%{summary}
 Icon=%{_datadir}/vlc/vlc48x48.png
 Exec=vlc
@@ -241,6 +250,10 @@ mv %{_libdir}/mozilla-%{mozver}/plugins/mozplugger.so %{_libdir}/mozilla/plugins
 %{_libdir}/libvlc.a
 
 %changelog
+* Tue Dec 2 2003 Jason Luka
+- Added fribidi support
+- Added fribidi and mkv options to configure
+
 * Sat Nov 29 2003 Jason Luka
 - Fixed Matroska/EBML problem
 - Updated script for mozilla plugin installation