]> git.sesse.net Git - vlc/blobdiff - vlc.spec
* ./include/vlc_threads.h, ./src/misc/threads.c: improved the cond_wait
[vlc] / vlc.spec
index b877a54a21ac7112060f8deb00ff9a7ebc52c460..bf050e81435d47b0cc7d939dd68b272b98e15e32 100644 (file)
--- a/vlc.spec
+++ b/vlc.spec
@@ -1,5 +1,7 @@
+
+
 %define name           vlc
-%define vlc_ver        0.3.0
+%define vlc_ver        0.5.0-cvs
 %define version                %vlc_ver
 
 %define cvs            0
 %define release                0.%{cvsdate}mdk
 %define cvs_name       %{name}-snapshot-%{cvsdate}-00
 %else
-%define release        2mdk
+%define release        1mdk
 %endif
 
 %define        plugin_qt       0
-%define        plugin_alsa     0
+%define        plugin_lirc     1
 
-Summary:       VideoLAN is a free MPEG, MPEG2 and DVD software solution.
+Summary:       VideoLAN is a free multimedia software solution.
 Name:          %{name}
 Version:       %{version}
 Release:       %{release}
+Packager:      Yves Duret <yduret@mandrakesoft.com>
 
 %if %{cvs} 
-Source0:       http://www.videolan.org/pub/videolan/vlc/snapshots/%{cvs_name}.tar.gz
+Source0:       http://www.videolan.org/pub/videolan/vlc/snapshots/%{cvs_name}.tar.bz2
 %else
-Source0:       http://www.videolan.org/packages/%{version}/%{name}-%{version}.tar.gz
+Source0:       http://www.videolan.org/packages/%{version}/%{name}-%{version}.tar.bz2
 %endif
 License:       GPL
 Group:         Video
-URL:           http://videolan.org/
+URL:           http://www.videolan.org/
+Requires:      vlc-gui
+# yves 0.4.0-1mdk needed by ffmpeg builtin (i want MPEG4 support out of box)
+Requires:      vlc-mad
+
 BuildRoot:     %_tmppath/%name-%version-%release-root
 Buildrequires: libncurses5-devel
 Buildrequires: libqt2-devel
@@ -34,10 +41,18 @@ Buildrequires:      libgtk+1.2-devel
 Buildrequires: gnome-libs-devel
 Buildrequires: db1-devel
 Buildrequires: alsa-lib-devel
+Buildrequires: libarts-devel
 Buildrequires: libggi-devel
+Buildrequires: aalib-devel
+Buildrequires: SDL-devel
+Buildrequires: liba52dec-devel
+Buildrequires: libmad-devel
+Buildrequires: liblirc-devel
+Buildrequires: libffmpeg-devel
 
 %description
-VideoLAN is a free network-aware MPEG and DVD player.
+VideoLAN is a free network-aware MPEG1, MPEG2, MPEG4 (aka DivX)
+and DVD player.
 The VideoLAN Client allows to play MPEG2 Transport Streams from the
 network or from a file, as well as direct DVD playback.
 VideoLAN is a project of students from the Ecole Centrale Paris.
@@ -45,115 +60,166 @@ This version add MPEG1 support, direct DVD support, DVD decryption,
 arbitrary, seeking in the stream, pause, fast forward and slow motion, 
 hardware YUV acceleration and a few new interface features 
 including drag'n'drop.
-You may install vlc-gnome, vlc-gtk and vlc-qt vlc-gnome vlc-ncurses.
+You may install vlc-gnome, vlc-gtk and vlc-ncurses.
 This package contains no CSS unscrambling functionality.
-You need the libdvdcss library available from http://www.videolan.org/libdvdcss/
+You need the libdvdcss library available from 
+http://www.videolan.org/libdvdcss/ or http://plf.zarb.org/
 
+# intf plugins
 %package gtk
-Summary: Gtk plug-in for VideoLAN, a DVD and MPEG2 player
+Summary: Gtk plugin for the VideoLAN client
 Group: Video
 Requires: %{name} = %{version}
+Provides: vlc-gui
 %description gtk
-The vlc-gtk packages includes the Gtk plug-in for the VideoLAN client.
-If you are going to watch DVD with the Gtk front-end, you should 
-install vlc-gtk.
+VideoLAN is a free multimedia software solution.
 
+This plugin adds a Gtk+ interface to vlc, the VideoLAN Client. To
+activate it, use the `--intf gtk' flag or run the `gvlc' program.
 
 %package gnome
-Summary: Gnome plug-in for VideoLAN, a DVD and MPEG2 player
+Summary: Gnome plugin for the VideoLAN client
 Group: Video
 Requires: %{name} = %{version}
+Provides: vlc-gui
 %description gnome
-The vlc-gnome packages includes the Gnome plug-in for the VideoLAN client.
-If you are going to watch DVD with the Gnome front-end, you should 
-install vlc-gnome.
+VideoLAN is a free multimedia software solution.
+
+This plugin adds a Gnome interface to vlc, the VideoLAN Client. To
+activate it, use the `--intf gnome' flag or run the `gnome-vlc' program.
 
 %package qt
-Summary: Qt2 plug-in for VideoLAN, a DVD and MPEG2 player
+Summary: Qt2 plugin for the VideoLAN client
 Group: Video
 Requires: %{name} = %{version}
+Provides: vlc-gui
 %description qt
-The vlc-qt packages includes the Qt2 plug-in for the VideoLAN client.
-If you are going to watch DVD with the Qt2 front-end, you should
-install vlc-qt
+VideoLAN is a free multimedia software solution.
+
+This plugin adds a Qt interface to vlc, the VideoLAN Client. To
+activate it, use the `--intf qt' flag or run the `qvlc' program.
 
 %package ncurses
-Summary: Ncurses console-based plug-in for VideoLAN, a DVD and MPEG2 player
+Summary: Ncurses console-based plugin for the VideoLAN client
 Group: Video
 Requires: %{name} = %{version}
 %description ncurses
-The vlc-ncurses packages includes the ncurses plug-in for the VideoLAN client.
-If you are going to watch DVD with the ncurses front-end, you should
-install vlc-ncurses
+VideoLAN is a free multimedia software solution.
+
+This plugin adds a ncurses interface to vlc, the VideoLAN Client. To
+activate it, use the `--intf ncurses' flag.
+
+%package lirc
+Summary: Lirc plugin for the VideoLAN client
+Group: Video
+Requires: %{name} = %{version}
+%description lirc
+VideoLAN is a free multimedia software solution.
+
+This plugin is an infrared lirc interface for vlc, the
+VideoLAN Client. To activate it, use the `--intf lirc' flag.
+
+
+# video plugins
+%package aa
+Summary: ASCII art video plugin for the VideoLAN client
+Group: Video
+Requires: %{name} = %{version}
+%description aa
+VideoLAN is a free multimedia software solution.
+
+This is an ASCII art video output plugin for vlc, the VideoLAN
+Client. To activate it, use the `--vout aa' flag or select the `aa'
+vout plugin from the preferences menu.
+
 
 %package sdl
-Summary: Simple DirectMedia Layer plug-in for VideoLAN, a DVD and MPEG2 player
+Summary: Simple DirectMedia Layer video plugin for the VideoLAN client
 Group: Video
 Requires: %{name} = %{version}
 %description sdl
-The vlc-sdl packages includes the Simple DirectMedia Layer plug-in 
-for the VideoLAN client.
-If you are going to watch DVD with the sdl plugin, you should
-install vlc-sdl
+VideoLAN is a free multimedia software solution.
+
+This plugin adds support for the Simple DirectMedia Layer library to
+vlc, the VideoLAN Client. To activate it, use the `--vout sdl' or
+`--aout sdl' flags or select the `sdl' vout or aout plugin from the
+preferences menu.
 
 %package ggi
-Summary: GGI plug-in for VideoLAN, a DVD and MPEG2 player
+Summary: GGI video plugin for the VideoLAN client
 Group: Video
 Requires: %{name} = %{version}
 %description ggi
-The vlc-ggi packages includes the GGI plug-in for the VideoLAN client.
-If you are going to watch DVD with the GGI plugin, you should
-install vlc-ggi
+VideoLAN is a free multimedia software solution.
+
+This is a GGI plugin for vlc, the VideoLAN Client.  To activate it, use
+the `--vout ggi' flag or select the `ggi' vout plugin from the preferences
+menu.
+     
+# codec plugins
+%package mad
+Summary: MAD audio codec plugin for the VideoLAN client
+Group: Video
+Requires: %{name} = %{version}
+%description mad
+VideoLAN is a free multimedia software solution.
 
+This plugin adds support for libmad, the MPEG audio decoder library,
+to the VideoLAN Client. MAD is 100% fixed-point based. To activate
+this plugin, use the `--mpeg_adec mad' flag or select the `mad' MPEG
+decoder from the preferences menu.
+
+# audio plugins
 %package esd
-Summary: Enlightened Sound Daemon plug-in for VideoLAN, a DVD and MPEG2 player
+Summary: Enlightened Sound Daemon audio plugin for the VideoLAN client
 Group: Video
 Requires: %{name} = %{version}
 %description esd
-The vlc-esd packages includes the Enlightened Sound Daemon plug-in 
-for the VideoLAN client.
-If you are going to watch DVD with the esd plugin, you should
-install vlc-esd
+VideoLAN is a free multimedia software solution.
+
+This plugin adds support for the Enlightened Sound Daemon to vlc, the
+VideoLAN Client. To activate it, use the `--aout esd' flag or select
+the `esd' aout plugin from the preferences menu.
+
+%package arts
+Summary: aRts audio plugin for the VideoLAN client
+Group: Video
+Requires: %{name} = %{version}
+%description arts
+VideoLAN is a free multimedia software solution.
+
+This plugin adds support for the aRts Sound System to vlc, the
+VideoLAN Client. To activate it, use the `--aout arts' flag or
+select the `arts' aout plugin from the preferences menu.
 
 %package alsa
-Summary: Advanced Linux Sound Architecture plug-in for VideoLAN, a DVD and MPEG2 player
+Summary: Advanced Linux Sound Architecture audio plugin for the VideoLAN client
 Group: Video
 Requires: %{name} = %{version}
 %description alsa
-The vlc-alsa packages includes the Advanced Linux Sound Architecture plug-in for the VideoLAN client.
-If you are going to watch DVD with the ALSA plugin, you should install vlc-alsa
+VideoLAN is a free multimedia software solution.
+
+This plugin adds support for the Advanced Linux Sound Architecture to
+vlc, the VideoLAN Client. To activate it, use the `--aout alsa' flag or
+select the `alsa' aout plugin from the preferences menu.
 
 %prep
 %if %{cvs}
 %setup -q -n %{cvs_name}
 %else
-%setup -q -n %{name}-%{vlc_ver}
+%setup -q
 %endif
 
 %build
-%ifarch ppc
-# Dadou - 0.1.99h-mdk - Don't use configure here. It breaks build at present
-#                       time.
-./configure --enable-release --enable-dvd --without-dvdcss \
-           --prefix=%_prefix \
-           --enable-gnome --enable-x11 --enable-gtk --enable-qt \
-           --enable-esd \
-           --enable-fb \
-           --enable-xvideo \
-           --enable-sdl
-perl -pi -e "s|CFLAGS \+= -mcpu=604e|#CFLAGS \+= -mcpu=604e|" Makefile
-perl -pi -e "s|#CFLAGS \+= -mcpu=750|CFLAGS \+= -mcpu=750 -mtune=750|" Makefile
-%else
-#export CC="gcc-3.0.1" CXX="g++-3.0.1"
-%configure --enable-release --enable-dvd --without-dvdcss \
-           --enable-gnome --enable-gtk \
-          --enable-x11 --disable-qt --enable-ncurses \
-          --enable-esd --enable-alsa \
-          --enable-fb --enable-mga \
-          --enable-xvideo \
-          --enable-ggi \
-          --enable-sdl 
-%endif
+# yves 0.4.0-1mdk
+# ffmpeg: static linking cause no official ffmpeg release aith a stable ABI
+# ffmpeg: no plugin posible on ia64 due to the static linking (can not put .a in a .so)
+%configure  --enable-release \
+            --enable-dvd --without-dvdcss \
+            --enable-gtk --enable-gnome --disable-qt --disable-kde --enable-ncurses --enable-lirc \
+            --enable-x11 --enable-xvideo --enable-ggi --enable-sdl --enable-fb --enable-mga --enable-aa \
+            --enable-esd --enable-alsa --enable-arts \
+           --enable-mad --enable-ffmpeg --with-ffmpeg=/usr
 export QTDIR=%{_libdir}/qt2 
 %make
 
@@ -163,37 +229,37 @@ install -d %buildroot/%_mandir/man1
 install doc/vlc.1 %buildroot/%_mandir/man1
 
 # menu
-mkdir -p $RPM_BUILD_ROOT/%{_menudir}
-cat > $RPM_BUILD_ROOT/%{_menudir}/vlc << EOF
-?package(vlc): command="%{_bindir}/vlc" hotkey="V" needs="X11" longtitle="VideoLAN is a free MPEG, MPEG2 and DVD software solution" section="Multimedia/Video" title="VideoLAN Client" icon="vlc.png" hints="Video"
+mkdir -p %buildroot/%{_menudir}
+cat > %buildroot/%{_menudir}/vlc << EOF
+?package(vlc): command="%{_bindir}/vlc" hotkey="V" needs="X11" longtitle="VideoLAN is a free multimedia software solution" section="Multimedia/Video" title="VideoLAN Client" icon="vlc.png" hints="Video"
 EOF
-cat > $RPM_BUILD_ROOT/%{_menudir}/vlc-gtk << EOF
-?package(vlc-gtk): command="%{_bindir}/gvlc" needs="X11" longtitle="VideoLAN is a free MPEG, MPEG2 and DVD software solution" section="Multimedia/Video" title="Gtk VideoLAN Client" icon="gvlc.png" hints="Video"
+cat > %buildroot/%{_menudir}/vlc-gtk << EOF
+?package(vlc-gtk): command="%{_bindir}/gvlc" needs="X11" longtitle="VideoLAN is a free multimedia software solution" section="Multimedia/Video" title="Gtk VideoLAN Client" icon="gvlc.png" hints="Video"
 EOF
-cat > $RPM_BUILD_ROOT/%{_menudir}/vlc-gnome << EOF
-?package(vlc-gnome): command="%{_bindir}/gnome-vlc" needs="X11" longtitle="VideoLAN is a free MPEG, MPEG2 and DVD software solution" section="Multimedia/Video" title="Gnome VideoLAN Client" icon="gnome-vlc.png" hints="Video"
+cat > %buildroot/%{_menudir}/vlc-gnome << EOF
+?package(vlc-gnome): command="%{_bindir}/gnome-vlc" needs="X11" longtitle="VideoLAN is a free multimedia software solution" section="Multimedia/Video" title="Gnome VideoLAN Client" icon="gnome-vlc.png" hints="Video"
 EOF
-cat > $RPM_BUILD_ROOT/%{_menudir}/vlc-qt << EOF
-?package(vlc-gnome): command="%{_bindir}/qvlc" needs="X11" longtitle="VideoLAN is a free MPEG, MPEG2 and DVD software solution" section="Multimedia/Video" title="Qt VideoLAN Client" icon="qvlc.png" hints="Video"
+cat > %buildroot/%{_menudir}/vlc-qt << EOF
+?package(vlc-gnome): command="%{_bindir}/qvlc" needs="X11" longtitle="VideoLAN is a free multimedia software solution" section="Multimedia/Video" title="Qt VideoLAN Client" icon="qvlc.png" hints="Video"
 EOF
 
 # icons
 mkdir -p %{buildroot}/{%{_miconsdir},%{_liconsdir}}
-install -m 644 %buildroot/%_datadir/videolan/vlc16x16.png %buildroot/%{_miconsdir}/vlc.png
-install -m 644 %buildroot/%_datadir/videolan/vlc32x32.png %buildroot/%{_iconsdir}/vlc.png
-install -m 644 %buildroot/%_datadir/videolan/vlc48x48.png %buildroot/%{_liconsdir}/vlc.png
-install -m 644 %buildroot/%_datadir/videolan/gnome-vlc16x16.png %buildroot/%{_miconsdir}/gnome-vlc.png
-install -m 644 %buildroot/%_datadir/videolan/gnome-vlc32x32.png %buildroot/%{_iconsdir}/gnome-vlc.png
-install -m 644 %buildroot/%_datadir/videolan/gnome-vlc48x48.png %buildroot/%{_liconsdir}/gnome-vlc.png
-install -m 644 %buildroot/%_datadir/videolan/gvlc16x16.png %buildroot/%{_miconsdir}/gvlc.png
-install -m 644 %buildroot/%_datadir/videolan/gvlc32x32.png %buildroot/%{_iconsdir}/gvlc.png
-install -m 644 %buildroot/%_datadir/videolan/gvlc48x48.png %buildroot/%{_liconsdir}/gvlc.png
-install -m 644 %buildroot/%_datadir/videolan/kvlc16x16.png %buildroot/%{_miconsdir}/kvlc.png
-install -m 644 %buildroot/%_datadir/videolan/kvlc32x32.png %buildroot/%{_iconsdir}/kvlc.png
-install -m 644 %buildroot/%_datadir/videolan/kvlc48x48.png %buildroot/%{_liconsdir}/kvlc.png
-install -m 644 %buildroot/%_datadir/videolan/qvlc16x16.png %buildroot/%{_miconsdir}/qvlc.png
-install -m 644 %buildroot/%_datadir/videolan/qvlc32x32.png %buildroot/%{_iconsdir}/qvlc.png
-install -m 644 %buildroot/%_datadir/videolan/qvlc48x48.png %buildroot/%{_liconsdir}/qvlc.png
+install -m 644 %buildroot/%_datadir/vlc/vlc16x16.png %buildroot/%{_miconsdir}/vlc.png
+install -m 644 %buildroot/%_datadir/vlc/vlc32x32.png %buildroot/%{_iconsdir}/vlc.png
+install -m 644 %buildroot/%_datadir/vlc/vlc48x48.png %buildroot/%{_liconsdir}/vlc.png
+install -m 644 %buildroot/%_datadir/vlc/gnome-vlc16x16.png %buildroot/%{_miconsdir}/gnome-vlc.png
+install -m 644 %buildroot/%_datadir/vlc/gnome-vlc32x32.png %buildroot/%{_iconsdir}/gnome-vlc.png
+install -m 644 %buildroot/%_datadir/vlc/gnome-vlc48x48.png %buildroot/%{_liconsdir}/gnome-vlc.png
+install -m 644 %buildroot/%_datadir/vlc/gvlc16x16.png %buildroot/%{_miconsdir}/gvlc.png
+install -m 644 %buildroot/%_datadir/vlc/gvlc32x32.png %buildroot/%{_iconsdir}/gvlc.png
+install -m 644 %buildroot/%_datadir/vlc/gvlc48x48.png %buildroot/%{_liconsdir}/gvlc.png
+install -m 644 %buildroot/%_datadir/vlc/kvlc16x16.png %buildroot/%{_miconsdir}/kvlc.png
+install -m 644 %buildroot/%_datadir/vlc/kvlc32x32.png %buildroot/%{_iconsdir}/kvlc.png
+install -m 644 %buildroot/%_datadir/vlc/kvlc48x48.png %buildroot/%{_liconsdir}/kvlc.png
+install -m 644 %buildroot/%_datadir/vlc/qvlc16x16.png %buildroot/%{_miconsdir}/qvlc.png
+install -m 644 %buildroot/%_datadir/vlc/qvlc32x32.png %buildroot/%{_iconsdir}/qvlc.png
+install -m 644 %buildroot/%_datadir/vlc/qvlc48x48.png %buildroot/%{_liconsdir}/qvlc.png
 
 %post
 %update_menus
@@ -204,52 +270,56 @@ install -m 644 %buildroot/%_datadir/videolan/qvlc48x48.png %buildroot/%{_liconsd
 rm -fr %buildroot
 
 %files
-%defattr(-,root,root,-)
+%defattr(-,root,root)
 %doc README COPYING
 %{_bindir}/vlc
-%dir %{_libdir}/videolan/vlc
-%{_libdir}/videolan/vlc/ac3_spdif.so
-%{_libdir}/videolan/vlc/dsp.so
-%{_libdir}/videolan/vlc/dummy.so
-%{_libdir}/videolan/vlc/dvd.so
-%{_libdir}/videolan/vlc/fb.so
-%{_libdir}/videolan/vlc/file.so
-%{_libdir}/videolan/vlc/filter_deinterlace.so
-%{_libdir}/videolan/vlc/filter_distort.so
-%{_libdir}/videolan/vlc/filter_invert.so
-%{_libdir}/videolan/vlc/filter_transform.so
-%{_libdir}/videolan/vlc/filter_wall.so
-%{_libdir}/videolan/vlc/fx_scope.so
-%{_libdir}/videolan/vlc/http.so
-%{_libdir}/videolan/vlc/ipv4.so
-%{_libdir}/videolan/vlc/ipv6.so
-%{_libdir}/videolan/vlc/logger.so
-%{_libdir}/videolan/vlc/lpcm_adec.so
-%{_libdir}/videolan/vlc/memcpy.so
-%{_libdir}/videolan/vlc/mga.so
-%{_libdir}/videolan/vlc/mpeg_es.so
-%{_libdir}/videolan/vlc/mpeg_ps.so
-%{_libdir}/videolan/vlc/mpeg_ts.so
-%{_libdir}/videolan/vlc/null.so
-%{_libdir}/videolan/vlc/rc.so
-%{_libdir}/videolan/vlc/spudec.so
-%{_libdir}/videolan/vlc/udp.so
-%{_libdir}/videolan/vlc/vcd.so
-%{_libdir}/videolan/vlc/x11.so
-%{_libdir}/videolan/vlc/xmga.so
-# nothing useful for the moment.
-#%dir %{_datadir}/videolan
-#%{_datadir}/videolan/*
+
+%dir %{_libdir}/vlc
+%{_libdir}/vlc/ac3_spdif.so
+%{_libdir}/vlc/avi.so
+%{_libdir}/vlc/dsp.so
+%{_libdir}/vlc/dummy.so
+%{_libdir}/vlc/dvd.so
+%{_libdir}/vlc/fb.so
+%{_libdir}/vlc/file.so
+%{_libdir}/vlc/filter_clone.so
+%{_libdir}/vlc/filter_crop.so
+%{_libdir}/vlc/filter_deinterlace.so
+%{_libdir}/vlc/filter_distort.so
+%{_libdir}/vlc/filter_invert.so
+%{_libdir}/vlc/filter_transform.so
+%{_libdir}/vlc/filter_wall.so
+%{_libdir}/vlc/fx_scope.so
+%{_libdir}/vlc/http.so
+%{_libdir}/vlc/ipv4.so
+%{_libdir}/vlc/ipv6.so
+%{_libdir}/vlc/logger.so
+%{_libdir}/vlc/lpcm_adec.so
+%{_libdir}/vlc/memcpy.so
+%{_libdir}/vlc/mga.so
+%{_libdir}/vlc/mpeg_es.so
+%{_libdir}/vlc/mpeg_ps.so
+%{_libdir}/vlc/mpeg_ts.so
+%{_libdir}/vlc/null.so
+%{_libdir}/vlc/rc.so
+%{_libdir}/vlc/spudec.so
+%{_libdir}/vlc/udp.so
+%{_libdir}/vlc/vcd.so
+%{_libdir}/vlc/x11.so
+#%{_libdir}/vlc/xmga.so
+
 %{_mandir}/man1/*
 %{_menudir}/vlc
 %{_miconsdir}/vlc.png
 %{_iconsdir}/vlc.png
 %{_liconsdir}/vlc.png
 
+
+# intf plugins
 %files gtk
 %defattr(-,root,root)
 %doc README
-%{_libdir}/videolan/vlc/gtk.so
+%{_libdir}/vlc/gtk.so
 %{_bindir}/gvlc
 %{_menudir}/vlc-gtk
 %{_miconsdir}/gvlc.png
@@ -263,7 +333,7 @@ rm -fr %buildroot
 %files gnome
 %defattr(-,root,root)
 %doc README
-%{_libdir}/videolan/vlc/gnome.so
+%{_libdir}/vlc/gnome.so
 %{_bindir}/gnome-vlc
 %{_menudir}/vlc-gnome
 %{_miconsdir}/gnome-vlc.png
@@ -278,7 +348,7 @@ rm -fr %buildroot
 %files qt
 %defattr(-,root,root)
 %doc README
-%{_libdir}/videolan/vlc/qt.so
+%{_libdir}/vlc/qt.so
 %{_bindir}/qvlc
 %{_menudir}/vlc-qt
 %{_miconsdir}/qvlc.png
@@ -293,35 +363,113 @@ rm -fr %buildroot
 %files ncurses
 %defattr(-,root,root)
 %doc README
-%{_libdir}/videolan/vlc/ncurses.so
+%{_libdir}/vlc/ncurses.so
+
+%if %plugin_lirc
+%files lirc
+%defattr(-,root,root)
+%doc README
+%{_libdir}/vlc/lirc.so
+%endif
 
+# video plugins
 %files sdl
 %defattr(-,root,root)
 %doc README
-%{_libdir}/videolan/vlc/sdl.so
+%{_libdir}/vlc/sdl.so
 
 %files ggi
 %defattr(-,root,root)
 %doc README
-%{_libdir}/videolan/vlc/ggi.so
+%{_libdir}/vlc/ggi.so
+
+%files aa
+%defattr(-,root,root)
+%doc README
+%{_libdir}/vlc/aa.so
+
+# codec plugin
+%files mad
+%defattr(-,root,root)
+%doc README
+%{_libdir}/vlc/mad.so
 
+#audio plugins
 %files esd
 %defattr(-,root,root)
 %doc README
-%{_libdir}/videolan/vlc/esd.so
+%{_libdir}/vlc/esd.so
+
+%files arts
+%defattr(-,root,root)
+%doc README
+%{_libdir}/vlc/arts.so
 
-%if %{plugin_alsa}
 %files alsa
 %defattr(-,root,root)
 %doc README
-%{_libdir}/videolan/vlc/alsa.so
-%endif
+%{_libdir}/vlc/alsa.so
 
 %changelog
-* Thu Apr 06 2002 Samuel Hocevar <sam@zoy.org> 0.3.0
-- version 0.3.0.
-- removed libdvdcss from the whole tarball.
-- removed the workaround for vlc's bad /dev/dsp detection.
+* Thu May 23 2002 Yves Duret <yduret@mandrakesoft.com> 0.4.0-1mdk
+- version 0.4.0 with MPEG4 (DivX) support thx ffmpeg.
+  thus s/MPEG, MPEG2 and DVD/multimedia/g
+- sync %%description with debian ones.
+- vlc now requires a vlc-gui (gtk, gnome or qt).
+- removed gcc3.1 patches since merged upstream.
+
+* Mon May 13 2002 Yves Duret <yduret@mandrakesoft.com> 0.3.1-4mdk
+- removed xmga plugin (currently broken).
+- manual rebuild in gcc3.1 environment aka added Patch0 & Patch1
+- various summary/description changes.
+
+* Fri May 03 2002 Yves Duret <yduret@mandrakesoft.com> 0.3.1-3mdk
+- added vlc-lirc intf plugin rpm.
+
+* Tue Apr 30 2002 Yves Duret <yduret@mandrakesoft.com> 0.3.1-2mdk
+- rebuild against libalsa2 (vlc-sdl)
+
+* Fri Apr 19 2002 Yves Duret <yduret@mandrakesoft.com> 0.3.1-1mdk
+- version 0.3.1.
+- removed patch0 merged upstream.
+- removed old %%ifarch ppc
+- added missing libmad-devel buldrequires
+
+* Wed Apr 17 2002 Yves Duret <yduret@mandrakesoft.com> 0.3.0-4mdk
+- added liba52 support (buildrequires).
+- added vlc-alsa audio plugin.
+- mad is a codec (audio) plugin. corrected description and summary.
+
+* Wed Apr 10 2002 Yves Duret <yduret@mandrakesoft.com> 0.3.0-3mdk
+- added patch0 from CVS: fix crashing GTK popup menus thx Michal Bukovjan <bukovjan@mbox.dkm.cz>
+
+* Wed Apr 10 2002 Yves Duret <yduret@mandrakesoft.com> 0.3.0-2mdk
+- added vlc-arts rpm plugin thx blindauer Emmanuel <manu@agat.net>
+- better summary for plugin
+- add packager tag to myself
+
+* Sun Apr 07 2002 Yves Duret <yduret@mandrakesoft.com> 0.3.0-1mdk
+- version 0.3.0
+- added aa (Asci Art) plugin in vlc-aa rpm
+- merged with sam's one:
+  * using his plugins list into %%files
+  * removed libdvdcss from the whole tarball.
+  * removed the workaround for vlc's bad /dev/dsp detection.
+- few spell corrections in all %%description
+- added buildrequires on SDL-devel
+
+* Tue Mar 05 2002 Yves Duret <yduret@mandrakesoft.com> 0.2.93-0.1mdk
+- new cvs snapshot
+- fix requires
+
+* Mon Mar 04 2002 Yves Duret <yduret@mandrakesoft.com> 0.2.92-5mdk
+- cvs snapshot
+
+* Sat Jan 26 2002 Yves Duret <yduret@mandrakesoft.com> 0.2.92-4mdk
+- mad plugin in vlc-mad rpm
+
+* Mon Jan 21 2002 Yves Duret <yduret@mandrakesoft.com> 0.2.92-3mdk
+- synced with main cvs specfile wich "fixed a few minor inaccuracies"
 
 * Thu Jan 17 2002 Yves Duret <yduret@mandrakesoft.com> 0.2.92-2mdk
 - readded libdvdcss rpm in specfile. use %%define css 1 with correct sources
@@ -365,11 +513,11 @@ rm -fr %buildroot
 - corrected Summary in vlc-qt
 
 * Wed May 23 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.73-2mdk
-- added qt2 plug-in (vlc-qt)
+- added qt2 plugin (vlc-qt)
 
 * Wed May 16 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.73-1mdk
 - version 0.2.73
-- you can now get decss threw a plug-in
+- you can now get decss threw a plugin
 - rewritte srcipt to build vlc (decss plugin)
 - rebuild with SDL 1.2