]> git.sesse.net Git - bcachefs-tools-debian/commitdiff
build: use 'find', not 'git', to locate C source code
authorAustin Seipp <aseipp@pobox.com>
Sun, 26 Nov 2017 06:55:12 +0000 (00:55 -0600)
committerAustin Seipp <aseipp@pobox.com>
Sun, 10 Dec 2017 22:03:32 +0000 (16:03 -0600)
We will not always have .git available in some cases. For example, if someone
simply downloaded a tarball of the tree, or if we're building with something
like Nix and want to exclude the .git folder, we need to cope and build the
source anyway.

Signed-off-by: Austin Seipp <aseipp@pobox.com>
Makefile

index a5ea2d0afaa38ccd2e60b3e7cd70e97c6d7ba7ea..6538fe78aa7ccea8d1c1c8de8f9ecd9fb562fb83 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -44,7 +44,7 @@ endif
 .PHONY: all
 all: bcachefs
 
-SRCS=$(shell git ls-files '*.c')
+SRCS=$(shell find . -type f -iname '*.c')
 DEPS=$(SRCS:.c=.d)
 -include $(DEPS)