]> git.sesse.net Git - bcachefs-tools-debian/commitdiff
Add a NO_RUST option
authorKent Overstreet <kent.overstreet@linux.dev>
Thu, 20 Apr 2023 16:35:27 +0000 (12:35 -0400)
committerKent Overstreet <kent.overstreet@linux.dev>
Thu, 20 Apr 2023 16:36:16 +0000 (12:36 -0400)
For systems without working rust/llvm/bindgen, add an option for
building without Rust. This will be less of an option in the future, as
more code gets rewritten in Rust.

Signed-off-by: Kent Overstreet <kent.overstreet@linux.dev>
Makefile
bcachefs.c

index 0793f2a2f235de0ef9993d151a2f7e60f5efcca1..31fb9ac07eaf605aaed6373233d5f83e9d952dcc 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -108,7 +108,15 @@ OBJS=$(SRCS:.c=.o)
        @echo "    [CC]     $@"
        $(Q)$(CC) $(CPPFLAGS) $(CFLAGS) -c -o $@ $<
 
-bcachefs: libbcachefs.a rust-src/target/release/libbcachefs_rust.a
+BCACHEFS_DEPS=libbcachefs.a
+
+ifndef NO_RUST
+       BCACHEFS_DEPS+=rust-src/target/release/libbcachefs_rust.a
+else
+       CFLAGS+=-DBCACHEFS_NO_RUST
+endif
+
+bcachefs: $(BCACHEFS_DEPS)
        @echo "    [LD]     $@"
        $(Q)$(CC) $(LDFLAGS) -Wl,--whole-archive $+ $(LOADLIBES) -Wl,--no-whole-archive $(LDLIBS) -o $@
 
index f6148e2903ff5ea099023a560a05556a40fc0c04..8616d554a14894c5c20c236018ff96465e5cd1d9 100644 (file)
@@ -35,9 +35,11 @@ static void usage(void)
             "  show-super               Dump superblock information to stdout\n"
             "  set-option               Set a filesystem option\n"
             "\n"
+#ifndef BCACHEFS_NO_RUST
             "Mount:\n"
             "  mount                    Mount a filesystem\n"
             "\n"
+#endif
             "Repair:\n"
             "  fsck                     Check an existing filesystem for errors\n"
             "\n"
@@ -85,7 +87,9 @@ static void usage(void)
             "Debug:\n"
             "These commands work on offline, unmounted filesystems\n"
             "  dump                     Dump filesystem metadata to a qcow2 image\n"
+#ifndef BCACHEFS_NO_RUST
             "  list                     List filesystem metadata in textual form\n"
+#endif
             "  list_journal             List contents of journal\n"
             "\n"
             "Miscellaneous:\n"
@@ -231,8 +235,10 @@ int main(int argc, char *argv[])
 
        if (!strcmp(cmd, "dump"))
                return cmd_dump(argc, argv);
+#ifndef BCACHEFS_NO_RUST
        if (!strcmp(cmd, "list"))
                return cmd_list(argc, argv);
+#endif
        if (!strcmp(cmd, "list_journal"))
                return cmd_list_journal(argc, argv);
        if (!strcmp(cmd, "kill_btree_node"))
@@ -240,11 +246,12 @@ int main(int argc, char *argv[])
 
        if (!strcmp(cmd, "setattr"))
                return cmd_setattr(argc, argv);
-
+#ifndef BCACHEFS_NO_RUST
        if (!strcmp(cmd, "mount")) {
                cmd_mount(argc, argv);
                return 0;
        }
+#endif
 
 #ifdef BCACHEFS_FUSE
        if (!strcmp(cmd, "fusemount"))