]> git.sesse.net Git - bcachefs-tools-debian/commitdiff
fixup! nix: overhaul build system.
authorDaniel Hill <daniel@gluo.nz>
Tue, 3 Jan 2023 08:38:11 +0000 (21:38 +1300)
committerDaniel Hill <daniel@gluo.nz>
Mon, 30 Jan 2023 23:10:36 +0000 (12:10 +1300)
Signed-off-by: Daniel Hill <daniel@gluo.nz>
base.nix
flake.nix

index 29c86ac852305ed530c5894beaf27f2e86663d7c..0253fd796cb3f92bf8542addfc5f14ef9c2d75dd 100644 (file)
--- a/base.nix
+++ b/base.nix
@@ -1,5 +1,4 @@
 { lib
-, doCheck ? true
 , stdenvNoCC
 , callPackage
 , nixosTests
@@ -7,11 +6,7 @@
 , binary
 , mount
 , versionString ? "0.1"
-, inShell ? false
-, debugMode ? inShell
-, testWithValgrind ? true
-, fuseSupport ? false
-, fuse3 ? null }:
+}:
 
 stdenvNoCC.mkDerivation {
   pname = "bcachefs-tools";
@@ -43,7 +38,6 @@ stdenvNoCC.mkDerivation {
     ln -s "$out/bin/bcachefs-mount" "$out/bin/mount.bcachefs"
     ln -s "$out/bin" "$out/sbin"
   '';
-  doCheck = doCheck; # needs bcachefs module loaded on builder
 
   passthru = {
     tests = {
index 567a3dc1d8cfdc1d011b81b8367c6e67ebce723f..9ebcc13d88cf0cc94b5c4646ff11d4f5ddb146a4 100644 (file)
--- a/flake.nix
+++ b/flake.nix
     utils.lib.eachDefaultSystem (system:
       let
         pkgs = nixpkgs.legacyPackages.${system};
-        binary = pkgs.callPackage ./binary.nix { };
+        binary = pkgs.callPackage ./binary.nix {
+            testWithValgrind = false;
+        };
         mount = pkgs.callPackage ./rust-src/mount/default.nix { inherit binary; };
         bcachefs = pkgs.callPackage ./base.nix {
           inherit binary mount;
-            testWithValgrind = false;
           };
       in {
         packages = {