]> git.sesse.net Git - bcachefs-tools-debian/commitdiff
Build with -fPIC
authorKent Overstreet <kent.overstreet@gmail.com>
Mon, 18 Oct 2021 20:57:08 +0000 (16:57 -0400)
committerKent Overstreet <kent.overstreet@gmail.com>
Mon, 18 Oct 2021 20:57:08 +0000 (16:57 -0400)
The changes to how we integrate with rust code mean that we now need to
be emitting position indepedent code.

Signed-off-by: Kent Overstreet <kent.overstreet@gmail.com>
Makefile

index dc56d7bb489a2a087784cd0af4b8ed5e6e06476e..e852381dd362447e6d1138c7e87b28e7fabcfc91 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -2,7 +2,7 @@ PREFIX?=/usr/local
 PKG_CONFIG?=pkg-config
 INSTALL=install
 PYTEST=pytest-3
-CFLAGS+=-std=gnu89 -O2 -g -MMD -Wall                           \
+CFLAGS+=-std=gnu89 -O2 -g -MMD -Wall -fPIC                             \
        -Wno-pointer-sign                                       \
        -fno-strict-aliasing                                    \
        -fno-delete-null-pointer-checks                         \