]> git.sesse.net Git - bcachefs-tools-debian/commitdiff
bcachefs-kernel.nix: rename sha256 function input
authorKayla Firestack <dev@kaylafire.me>
Tue, 19 Oct 2021 19:25:33 +0000 (15:25 -0400)
committerKayla Firestack <dev@kaylafire.me>
Wed, 20 Oct 2021 18:47:28 +0000 (14:47 -0400)
overlay.nix: rename diffHash to sha256

replaces diffHash function argument with the name sha256 for clarity

Signed-off-by: Kayla Firestack <dev@kaylafire.me>
nix/bcachefs-kernel.nix
nix/overlay.nix

index 2e4f339d75c3bff0de2260957941d139ea689d02..c937df4c40725c4714f4f579fa062a01296e98d8 100644 (file)
@@ -4,7 +4,7 @@
 , fetchFromGitHub
 , buildLinux
 , commit
-, diffHash ? lib.fakeSha256
+, sha256 ? lib.fakeSha256
 , kernelVersion ? "5.13.0"
 , kernelPatches ? [] # must always be defined in bcachefs' all-packages.nix entry because it's also a top-level attribute supplied by callPackage
 , argsOverride ? {}
@@ -26,7 +26,7 @@ buildLinux {
                owner = "koverstreet";
                repo = "bcachefs";
                rev = commit;
-               sha256 = diffHash;
+               inherit sha256;
        };
 
        extraConfig = "BCACHEFS_FS m";
index 947242bac294803b955adfee8814f606114866c6..9c33396f7701ff0b9032b09e50f4b9688790e33f 100644 (file)
@@ -22,7 +22,7 @@ final: prev: {
                kernel = final.callPackage ./bcachefs-kernel.nix {
                        commit = final.bcachefs.tools.bcachefs_revision;
                        # This needs to be recalculated for every revision change
-                       diffHash = "sha256-XSA0dBZZL8RXplgjpoLOFSULM8t/0Ztz8xlhLn9hdyw=";
+                       sha256 = "sha256-XSA0dBZZL8RXplgjpoLOFSULM8t/0Ztz8xlhLn9hdyw=";
                        kernelPatches = [];
                };
        };