]> git.sesse.net Git - bcachefs-tools-debian/commitdiff
add bcachefs xor / xxhash support
authorjpsollie <janpieter.sollie@edpnet.be>
Wed, 30 Jun 2021 10:35:36 +0000 (12:35 +0200)
committerKent Overstreet <kent.overstreet@gmail.com>
Thu, 8 Jul 2021 00:30:39 +0000 (20:30 -0400)
Following the initial xxhash / xor checksum support patches in kernel, bcachefs-tools needs some updated libraries as well.
Unfortunately, xor functionality is deeply linked into several low-level functions, so we're adding a set of patches here to translate those into userspace

Signed-off-by: Janpieter Sollie <janpieter.sollie@edpnet.be>
Makefile

index 1bc6542ada4cb275b39f225401b4e407509a3e64..b544e81a70ae002b08a077204fde7f68302c0052 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -156,6 +156,10 @@ update-bcachefs-sources:
        git add libbcachefs/*.[ch]
        cp $(LINUX_DIR)/include/trace/events/bcachefs.h include/trace/events/
        git add include/trace/events/bcachefs.h
+       cp $(LINUX_DIR)/include/linux/xxhash.h include/linux/
+       git add include/linux/xxhash.h
+       cp $(LINUX_DIR)/lib/xxhash.c linux/
+       git add linux/xxhash.c
        cp $(LINUX_DIR)/kernel/locking/six.c linux/
        git add linux/six.c
        cp $(LINUX_DIR)/include/linux/six.h include/linux/