]> git.sesse.net Git - bcachefs-tools-debian/commitdiff
update version and build
authorClaudio Fleiner <cmf@daterainc.com>
Wed, 24 Dec 2014 18:18:26 +0000 (10:18 -0800)
committerClaudio Fleiner <cmf@daterainc.com>
Wed, 24 Dec 2014 18:18:26 +0000 (10:18 -0800)
Change-Id: I2f9e09ee6a927f7f89207914745ef50b6493e4b9

autogen.sh [deleted file]
bcache-tools.spec
configure.ac

diff --git a/autogen.sh b/autogen.sh
deleted file mode 100755 (executable)
index 8a566d4..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-#!/bin/bash
-
-set -e
-
-export ACLOCAL_FLAGS=""
-export ACLOCAL_AMFLAGS="-I m4"
-
-aclocal $ACLOCAL_FLAGS
-
-if glibtoolize -h > /dev/null 2>&1 ; then
-   glibtoolize --copy --force
-else
-   libtoolize --copy --force
-fi
-
-autoheader
-automake --copy --add-missing --foreign -Wall -Wno-portability
-autoconf
index 5242ee2f1cccaff43c21ded86983fb270a53087a..1f71ee19eda330a5a1e2d30ba11c3d8ed7c3b5fc 100644 (file)
@@ -1,9 +1,9 @@
-Summary: bcache-tools
-Name: bcache-tools
-Version: 0.1
+Summary: bcache-tools: manage local bcache devices
+Name: %{package_name}
+Version: %{datera_version}
 Release: %{?release:%{release}}%{!?release:eng}
 Source0: %{name}-%{version}.tar.gz
-License: GPL
+License: GPL2
 Group: tools
 BuildRoot: %{_tmppath}/%{name}-root
 Requires: libblkid
@@ -14,4 +14,17 @@ Summary: tools to manage bcache
 %description
 bcache tools
 
+%install
+make DESTDIR=%buildroot INSTALL=/usr/bin/install -C /bld/$RPM_PACKAGE_NAME install
+
 %files
+%_bindir/bcacheadm
+%_bindir/bcachectl
+%_bindir/make-bcache
+%_bindir/probe-bcache
+%_bindir/bcache-super-show
+%_prefix/etc/initramfs-tools/hooks/bcache
+%_prefix/lib/udev/bcache-register
+%_prefix/lib/udev/rules.d/69-bcache.rules
+%_libdir/libbcache.a
+%_mandir/man8/*.gz
index cf75d3529737eba8ef2a217daa586f900a26d371..5c86f950bd27d0262a95fd8c3fdb39a65045cffb 100644 (file)
@@ -2,22 +2,12 @@
 # Process this file with autoconf to produce a configure script.
 
 AC_PREREQ(2.61)
-AC_INIT(bcache-tools, 0.1, support@datera.io)
-AM_INIT_AUTOMAKE
+AC_INIT(m4_esyscmd([echo -n $PACKAGE]), m4_esyscmd([echo -n $DATERA_VERSION]), m4_esyscmd([echo -n $SUPPORT_EMAIL]))
 LT_INIT
 AC_CONFIG_HEADER([config.h])
 AC_CONFIG_MACRO_DIR([m4])
 
-# Checks for programs.
-AC_PROG_CC
-
-# Checks for libraries.
-
-# Checks for header files.
-
-# Checks for typedefs, structures, and compiler characteristics.
-
-# Checks for library functions.
+m4_include([../BTools/cscript/ccpp.m4])
 
 AC_CONFIG_FILES([Makefile])
 AC_OUTPUT