]> git.sesse.net Git - bcachefs-tools-debian/commitdiff
bcachefs-tools: make 'all' the default Makefile goal
authorTero Roponen <tero.roponen@gmail.com>
Fri, 8 Dec 2023 08:10:52 +0000 (10:10 +0200)
committerKent Overstreet <kent.overstreet@linux.dev>
Fri, 8 Dec 2023 20:07:32 +0000 (15:07 -0500)
"fsck/bcachefsck_all:" coming before "all:" in the Makefile
causes the bcachefs binary not being built by default. Fix
this by explicitly setting the .DEFAULT_GOAL=all.

Signed-off-by: Tero Roponen <tero.roponen@gmail.com>
Signed-off-by: Kent Overstreet <kent.overstreet@linux.dev>
Makefile

index a7926f46dec03dedae85f20fc11bdbca32368188..177ee45efe93bfd18d727c356fa79e1d3e02827b 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -4,6 +4,7 @@ PREFIX?=/usr/local
 PKG_CONFIG?=pkg-config
 INSTALL=install
 LN=ln
+.DEFAULT_GOAL=all
 
 ifeq ("$(origin V)", "command line")
   BUILD_VERBOSE = $(V)