]> git.sesse.net Git - bcachefs-tools-debian/commitdiff
Add Fedora, Ubuntu, Arch info to INSTALL
authorBrendon Boldt <brendon.boldt@gmail.com>
Fri, 6 Dec 2019 05:51:10 +0000 (00:51 -0500)
committerBrendon Boldt <brendon.boldt@gmail.com>
Fri, 6 Dec 2019 16:19:42 +0000 (11:19 -0500)
Add fuse3 (>=3.7) version to Makefile

INSTALL
Makefile

diff --git a/INSTALL b/INSTALL
index 0c37c4a07e42bd00549cfaa0d92b263449be6ceb..69987ca3d343fce1b670d73d343d3f1e29d8b15f 100644 (file)
--- a/INSTALL
+++ b/INSTALL
@@ -15,11 +15,21 @@ Dependencies:
  * zlib1g
  * valgrind
 
-On debian, you can install these with
+Debian (Bullseye or later) and Ubuntu (20.04 or later): you can install these with
     apt install -y pkg-config libaio-dev libblkid-dev libkeyutils-dev \
         liblz4-dev libscrypt-dev libsodium-dev liburcu-dev libzstd-dev \
         uuid-dev zlib1g-dev valgrind
 
+Fedora: install the "Development tools" group along with:
+    dnf install -y libaio-devel libsodium-devel \
+        libblkid-devel libzstd-devel zlib-devel userspace-rcu-devel \
+        lz4-devel libuuid-devel valgrind-devel keyutils-libs-devel \
+        libscrypt-devel findutils
+
+Arch: install bcachefs-tools-git from the AUR.
+Or to build from source, install libscrypt from the AUR along with,
+    pacman -S base-devel libaio keyutils libsodium liburcu zstd valgrind
+
 Then, just make && make install
 
 
@@ -29,14 +39,20 @@ Experimental fuse support is currently disabled by default. Fuse support is at
 an early stage and may corrupt your filesystem, so it should only be used for
 testing. To enable, you'll also need to add:
 
-* libfuse3
+* libfuse3 >= 3.7
 
-On debian:
+On Debian/Ubuntu (Bullseye/20.04 or later needed for libfuse >= 3.7):
     apt install -y libfuse3-dev
 
+On Fedora (32 or later needed for lbifuse >= 3.7):
+    dnf install -y fuse3-devel
+
+Arch:
+    pacman -S fuse3
+
 Then, make using the BCACHEFS_FUSE environment variable:
 
-BCACHEFS_FUSE=1 make &&
+BCACHEFS_FUSE=1 make && make install
 
 
 -- Tests --
@@ -50,6 +66,8 @@ On debian:
 Then, you can run the tests via:
 
     make check
+    # or if pytest has a different name
+    make check PYTEST=pytest
 
 Optionally, you may wish to run tests in parallel using python3-pytest-xdist:
 
index 5bd696a2e842b28d336f2aa23ff3b5c5e5f67e70..2f6531b6289691cfbc9d6215aae7fe5c913632e5 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -41,7 +41,7 @@ endif
 
 PKGCONFIG_LIBS="blkid uuid liburcu libsodium zlib liblz4 libzstd"
 ifdef BCACHEFS_FUSE
-       PKGCONFIG_LIBS+="fuse3"
+       PKGCONFIG_LIBS+="fuse3 >= 3.7"
        CFLAGS+=-DBCACHEFS_FUSE
 endif