]> git.sesse.net Git - bcachefs-tools-debian/commitdiff
Don't add commit id to version when building from a tag
authorTim Schlueter <schlueter.tim@linux.com>
Sun, 27 May 2018 19:38:51 +0000 (12:38 -0700)
committerTim Schlueter <schlueter.tim@linux.com>
Sun, 27 May 2018 19:39:05 +0000 (12:39 -0700)
Makefile

index 57ed873e884118d4a0d67616c5a5b809ce20bc59..21b51c301672bf29505d31df8257b26884494c2a 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -17,7 +17,7 @@ CFLAGS+=-std=gnu89 -O2 -g -MMD -Wall                          \
        $(EXTRA_CFLAGS)
 LDFLAGS+=$(CFLAGS)
 
-VERSION?=$(shell git describe --long --dirty 2>/dev/null || echo 0.1-nogit)
+VERSION?=$(shell git describe --dirty 2>/dev/null || echo 0.1-nogit)
 
 CC_VERSION=$(shell $(CC) -v 2>&1|grep -E '(gcc|clang) version')