]> git.sesse.net Git - bcachefs-tools-debian/commitdiff
Merge pull request #2 from modelrockettier/master
authorkoverstreet <kent.overstreet@gmail.com>
Mon, 12 Feb 2018 02:03:36 +0000 (21:03 -0500)
committerGitHub <noreply@github.com>
Mon, 12 Feb 2018 02:03:36 +0000 (21:03 -0500)
Improve Debian Package Builds

Makefile
debian/compat
debian/rules

index e773b467862ce155e17c6c47c153148d9f7561ea..ef1eacf7b0069aeb5def81900a9ae9f871743e90 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -71,12 +71,9 @@ clean:
 
 .PHONY: deb
 deb: all
-       debuild --unsigned-source       \
-               --unsigned-changes      \
-               --no-pre-clean          \
-               --build=binary          \
-               --diff-ignore           \
-               --tar-ignore
+# --unsigned-source --unsigned-changes --no-pre-clean --build=binary
+# --diff-ignore --tar-ignore
+       debuild -us -uc -nc -b -i -I
 
 .PHONE: update-bcachefs-sources
 update-bcachefs-sources:
index ec635144f60048986bc560c5576355344005e6e7..f599e28b8ab0d8c9c57a486c89c4a5132dcbd3b2 100644 (file)
@@ -1 +1 @@
-9
+10
index 4f2c774f2d13e882699e4351a4ebdcc61a688133..ae98f5cebb8cb017bc739a3dd7e7f91f2f2a07cc 100755 (executable)
@@ -1,4 +1,9 @@
 #!/usr/bin/make -f
+
+PREFIX := /usr
+
 %:
        dh $@
 
+override_dh_auto_install:
+       dh_auto_install -- "PREFIX=$(PREFIX)"