]> git.sesse.net Git - bcachefs-tools-debian/commitdiff
Makefile: build with -Wno-deprecated-declarations
authorKent Overstreet <kent.overstreet@linux.dev>
Wed, 1 Feb 2023 21:27:32 +0000 (16:27 -0500)
committerKent Overstreet <kent.overstreet@linux.dev>
Wed, 1 Feb 2023 21:34:14 +0000 (16:34 -0500)
This fixes a ZSTD warning.

Signed-off-by: Kent Overstreet <kent.overstreet@linux.dev>
Makefile

index 00e7b7c2544955d145caf98a3fd847018e23ca7a..743f6ca933488d0578fd62e7621abaeb43b6d82f 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -17,6 +17,7 @@ endif
 
 CFLAGS+=-std=gnu11 -O2 -g -MMD -Wall -fPIC                     \
        -Wno-pointer-sign                                       \
+       -Wno-deprecated-declarations                            \
        -fno-strict-aliasing                                    \
        -fno-delete-null-pointer-checks                         \
        -I. -Iinclude -Iraid                                    \