]> git.sesse.net Git - bcachefs-tools-debian/commitdiff
minor fixes for clang support
authorBrett Holman <bpholman5@gmail.com>
Thu, 20 May 2021 03:07:47 +0000 (21:07 -0600)
committerKent Overstreet <kent.overstreet@gmail.com>
Thu, 20 May 2021 03:26:13 +0000 (23:26 -0400)
Makefile
libbcachefs.c
smoke_test

index 3fe9604896513eed03b429965cca1bf4202f1c23..8f23ef6179cb1c9787d3b24e79d016f8df994172 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,12 +1,9 @@
-
 PREFIX?=/usr/local
 PKG_CONFIG?=pkg-config
 INSTALL=install
 PYTEST=pytest-3
 CFLAGS+=-std=gnu89 -O2 -g -MMD -Wall                           \
        -Wno-pointer-sign                                       \
-       -Wno-zero-length-bounds                                 \
-       -Wno-stringop-overflow                                  \
        -fno-strict-aliasing                                    \
        -fno-delete-null-pointer-checks                         \
        -I. -Iinclude -Iraid                                    \
@@ -28,11 +25,16 @@ VERSION?=$(shell git describe --dirty=+ 2>/dev/null || echo v0.1-nogit)
 CC_VERSION=$(shell $(CC) -v 2>&1|grep -E '(gcc|clang) version')
 
 ifneq (,$(findstring gcc,$(CC_VERSION)))
-       CFLAGS+=-Wno-unused-but-set-variable
+       CFLAGS+=-Wno-unused-but-set-variable                    \
+               -Wno-zero-length-bounds                         \
+               -Wno-stringop-overflow
 endif
 
 ifneq (,$(findstring clang,$(CC_VERSION)))
-       CFLAGS+=-Wno-missing-braces
+       CFLAGS+=-Wno-missing-braces                             \
+               -Wno-zero-length-array                          \
+               -Wno-shift-overflow                             \
+               -Wno-enum-conversion
 endif
 
 ifdef D
index fbcb237f50f620c44335adaa6a2f594227400272..65ca07e2d7d57e13bab3f1a977e8bd9a2b01aa58 100644 (file)
@@ -1100,22 +1100,17 @@ struct bch_opts bch2_parse_opts(struct bch_opt_strs strs)
        return opts;
 }
 
+#define newline(c)             \
+       do {                    \
+               printf("\n");   \
+               c = 0;          \
+       } while(0)
 void bch2_opts_usage(unsigned opt_types)
 {
        const struct bch_option *opt;
        unsigned i, c = 0, helpcol = 30;
 
-       void tabalign() {
-               while (c < helpcol) {
-                       putchar(' ');
-                       c++;
-               }
-       }
 
-       void newline() {
-               printf("\n");
-               c = 0;
-       }
 
        for (opt = bch2_opt_table;
             opt < bch2_opt_table + bch2_opts_nr;
@@ -1146,21 +1141,24 @@ void bch2_opts_usage(unsigned opt_types)
                        const char *l = opt->help;
 
                        if (c >= helpcol)
-                               newline();
+                               newline(c);
 
                        while (1) {
                                const char *n = strchrnul(l, '\n');
 
-                               tabalign();
+                               while (c < helpcol) {
+                                       putchar(' ');
+                                       c++;
+                               }
                                printf("%.*s", (int) (n - l), l);
-                               newline();
+                               newline(c);
 
                                if (!*n)
                                        break;
                                l = n + 1;
                        }
                } else {
-                       newline();
+                       newline(c);
                }
        }
 }
index 076806d8a93b2e694713df6a9bdb2eca4a7ea432..43cfabfb685e3466fe593f11428580ce9b3e3efa 100755 (executable)
@@ -20,6 +20,7 @@
 
 set -e
 
+PYTEST=pytest-3
 spam=$(tempfile)
 unset BCACHEFS_FUSE BCACHEFS_TEST_USE_VALGRIND D
 
@@ -44,7 +45,7 @@ function test() {
     echo Running tests.
     (
         cd tests
-        pytest-3 -n${JOBS}
+        ${PYTEST} -n${JOBS}
     ) > ${spam} 2>&1
 }
 
@@ -53,7 +54,7 @@ function test_vg() {
     (
         export BCACHEFS_TEST_USE_VALGRIND=yes
         cd tests
-        pytest-3 -n${JOBS}
+        ${PYTEST} -n${JOBS}
     ) > ${spam} 2>&1
 }