]> git.sesse.net Git - bcachefs-tools-debian/commitdiff
fix "no rst2man found!" build error on debian and ubuntu
authorIgor Velkov <iav@iav.lv>
Mon, 18 Oct 2021 20:37:40 +0000 (23:37 +0300)
committerKent Overstreet <kent.overstreet@gmail.com>
Mon, 18 Oct 2021 21:41:11 +0000 (17:41 -0400)
Makefile

index e852381dd362447e6d1138c7e87b28e7fabcfc91..ee3f8fbc72eb516750582f5fdf8547b5c0afd882 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -66,14 +66,12 @@ else
        INITRAMFS_DIR=/etc/initramfs-tools
 endif
 
-STATUS:=$(shell rst2man -V 2>/dev/null; echo $$?)
-ifeq ($(STATUS),0)
-       RST2MAN=rst2man
-endif
-
-STATUS:=$(shell rst2man.py -V 2>/dev/null; echo $$?)
-ifeq ($(STATUS),0)
-       RST2MAN=rst2man.py
+RST2MAN:=$(shell which rst2man)
+ifeq ($(RST2MAN),)
+       RST2MAN:=$(shell which rst2man.py)
+       ifeq ($(RST2MAN),)
+               @echo "WARNING: no rst2man found! Man page not generated."
+       endif
 endif
 
 .PHONY: all