]> git.sesse.net Git - bcachefs-tools-debian/commitdiff
bcachefs-tools: Disable -Wgnu-variable-sized-type-not-at-end for clang
authorChris Webb <chris@arachsys.com>
Sat, 9 Dec 2023 14:31:40 +0000 (14:31 +0000)
committerKent Overstreet <kent.overstreet@linux.dev>
Sun, 10 Dec 2023 04:29:04 +0000 (23:29 -0500)
clang's default warnings include -Wgnu-variable-sized-type-not-at-end,
producing a lot of false alarms about the GNU extension for libbcachefs.
Disable these using cc-disable-warning when building with clang.

Signed-off-by: Chris Webb <chris@arachsys.com>
Signed-off-by: Kent Overstreet <kent.overstreet@linux.dev>
Makefile

index 177ee45efe93bfd18d727c356fa79e1d3e02827b..5693c0ea6a6219af77169fa8a8acca48c4b75e27 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -59,6 +59,7 @@ CFLAGS+=$(call cc-disable-warning, missing-braces)
 CFLAGS+=$(call cc-disable-warning, zero-length-array)
 CFLAGS+=$(call cc-disable-warning, shift-overflow)
 CFLAGS+=$(call cc-disable-warning, enum-conversion)
+CFLAGS+=$(call cc-disable-warning, gnu-variable-sized-type-not-at-end)
 
 PKGCONFIG_LIBS="blkid uuid liburcu libsodium zlib liblz4 libzstd libudev libkeyutils udev"
 ifdef BCACHEFS_FUSE