]> git.sesse.net Git - bcachefs-tools-debian/commitdiff
Fix build dependencies
authorKent Overstreet <kent.overstreet@linux.dev>
Sun, 19 Mar 2023 19:32:43 +0000 (15:32 -0400)
committerKent Overstreet <kent.overstreet@linux.dev>
Sun, 19 Mar 2023 19:32:43 +0000 (15:32 -0400)
Incremental builds are fast again

Signed-off-by: Kent Overstreet <kent.overstreet@linux.dev>
Makefile

index cd85880ab531dd5a27179289a9d6f344682f2f4c..8a85e01ce20f16ff5ff416f060375c5063ffb0e2 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -132,8 +132,8 @@ libbcachefs.a: $(filter-out ./tests/%.o, $(OBJS))
        @echo "    [AR]     $@"
        $(Q)ar -rc $@ $+
 
-RUST_SRCS=$(shell find rust-src/ -type f -iname '*.rs')
-rust-src/target/release/libbcachefs_rust.a: libbcachefs.a $(RUST_SRCS)
+RUST_SRCS=$(shell find rust-src/src rust-src/bch_bindgen/src -type f -iname '*.rs')
+rust-src/target/release/libbcachefs_rust.a: $(RUST_SRCS)
        $(CARGO_BUILD) --manifest-path rust-src/Cargo.toml
 
 tests/test_helper: $(filter ./tests/%.o, $(OBJS))