]> git.sesse.net Git - bcachefs-tools-debian/commitdiff
Minor cleanup
authorKent Overstreet <kmo@daterainc.com>
Sun, 15 Mar 2015 22:49:05 +0000 (15:49 -0700)
committerKent Overstreet <kmo@daterainc.com>
Sun, 15 Mar 2015 22:50:07 +0000 (15:50 -0700)
Makefile
bcacheadm.c

index 34d86947cb152778a83b76546929abf6413fb56b..60abbd87d0d197785b0daa6a72d97f3792c8d96a 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -3,7 +3,8 @@ PREFIX=/usr
 UDEVLIBDIR=/lib/udev
 DRACUTLIBDIR=/lib/dracut
 INSTALL=install
-CFLAGS+=-std=gnu99 -O2 -Wall -Werror -g -I.
+CFLAGS+=-std=gnu99 -O2 -Wall -Werror -g -Iinclude
+LDFLAGS+=-static
 
 all: bcacheadm probe-bcache
 
index d6e2d8698aad2e5495e8d8301e5bccf33ed1478c..792b5b7986440f95ccbfdf1d7f3f67ee4ef90e34 100644 (file)
 #include <stdint.h>
 #include <blkid.h>
 #include <string.h>
-#include <linux/fs.h>
 #include <sys/ioctl.h>
 #include <sys/types.h>
 #include <sys/stat.h>
 #include <uuid/uuid.h>
 #include <dirent.h>
-#include <bcache.h> //libbcache
+#include "bcache.h" //libbcache
 
 #define PACKAGE_NAME "bcacheadm"
 #define PACKAGE_VERSION "1.0"