]> git.sesse.net Git - casparcg/blobdiff - dependencies64/cef/windows/tests/gtest/CMakeLists.txt
Upgrade CEF to 3.3029.1611.g44e39a8 / Chromium 58.0.3029.81.
[casparcg] / dependencies64 / cef / windows / tests / gtest / CMakeLists.txt
diff --git a/dependencies64/cef/windows/tests/gtest/CMakeLists.txt b/dependencies64/cef/windows/tests/gtest/CMakeLists.txt
new file mode 100644 (file)
index 0000000..c4daa89
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 2016 The Chromium Embedded Framework Authors. All rights\r
+# reserved. Use of this source code is governed by a BSD-style license that\r
+# can be found in the LICENSE file.\r
+\r
+set(CEF_TARGET "cef_gtest")\r
+\r
+set(GTEST_SRCS\r
+  src/gtest-all.cc\r
+  )\r
+source_group(cef_gtest FILES ${GTEST_SRCS})\r
+\r
+add_library(${CEF_TARGET} ${GTEST_SRCS})\r
+\r
+# Start with CEF default properties.\r
+SET_LIBRARY_TARGET_PROPERTIES(${CEF_TARGET})\r
+\r
+# The gtest-all.cc file uses #include "gtest/gtest.h"\r
+target_include_directories(${CEF_TARGET} PRIVATE "include")\r
+\r
+# In order to allow regex matches in gtest to be shared between Windows\r
+# and other systems we tell gtest to always use it's internal engine.\r
+target_compile_definitions(${CEF_TARGET} PRIVATE -DGTEST_HAS_POSIX_RE=0 -DGTEST_LANG_CXX11=1)\r
+\r
+# All dependent targets are unit tests.\r
+target_compile_definitions(${CEF_TARGET} PUBLIC -DUNIT_TEST)\r
+\r
+if(OS_WINDOWS)\r
+  # Disable unused variable warning.\r
+  target_compile_options(${CEF_TARGET} PRIVATE "/wd4800")\r
+endif()\r