]> git.sesse.net Git - itkacl/blobdiff - perl-itkacl-2.0/debian/rules
Use the new library context system in the Perl module.
[itkacl] / perl-itkacl-2.0 / debian / rules
diff --git a/perl-itkacl-2.0/debian/rules b/perl-itkacl-2.0/debian/rules
deleted file mode 100755 (executable)
index 3b2aefe..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-#!/usr/bin/make -f
-
-build:
-       dh_testdir
-       swig -perl5 itkacl.i
-       perl Makefile.PL INSTALLDIRS=vendor
-       $(MAKE) OPTIMIZE="-O2 -g -Wall"
-
-clean:
-       dh_testdir
-       dh_clean
-       [ ! -f Makefile ] || $(MAKE) distclean
-       $(RM) itkacl.pm itkacl_wrap.c
-
-binary-indep:
-
-binary-arch:
-       dh_testroot
-       dh_prep
-       dh_installdirs
-       $(MAKE) install DESTDIR=$(CURDIR)/debian/libitkacl-perl
-       dh_install
-       dh_perl
-       dh_compress
-       dh_fixperms
-       dh_strip
-       dh_makeshlibs
-       dh_shlibdeps
-       dh_installdeb
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-arch