]> git.sesse.net Git - nageru/blobdiff - shared/meson.build
Give Futatabi an about/license dialog, and the same manual link as Nageru.
[nageru] / shared / meson.build
index acb2c9a251f46e7e77db3eb3455e85e7ca1d914b..49c52ee65bc6743d4b969ec299c3a3c5b3dbf826 100644 (file)
@@ -1,8 +1,19 @@
 qt5 = import('qt5')
-qt5deps = dependency('qt5', modules: ['OpenGL'])
+qt5deps = dependency('qt5', modules: ['Core', 'Gui', 'Widgets', 'OpenGL'])
 libmicrohttpddep = dependency('libmicrohttpd')
 
+# Preprocess Qt as needed.
+qt_files = qt5.preprocess(
+       moc_headers: ['aboutdialog.h'],
+       ui_files: ['aboutdialog.ui'],
+       dependencies: qt5deps)
+
 srcs = ['memcpy_interleaved.cpp', 'metacube2.cpp', 'ffmpeg_raii.cpp', 'mux.cpp', 'metrics.cpp', 'context.cpp', 'httpd.cpp', 'disk_space_estimator.cpp', 'read_file.cpp']
+
+# Qt objects.
+srcs += qt_files
+srcs += ['aboutdialog.cpp']
+
 shared = static_library('shared', srcs, include_directories: top_include, dependencies: [qt5deps, libmicrohttpddep])
 shareddep = declare_dependency(
    include_directories: top_include,