]> git.sesse.net Git - kdenlive/blobdiff - src/CMakeLists.txt
jogshuttle: cmake files cleaned up a little bit
[kdenlive] / src / CMakeLists.txt
index c784aafcc3dc15edca7bddd6f99954387b9a378c..aedb54d45f982fa46b80cf5bc7b00c3598f1b16f 100644 (file)
@@ -111,20 +111,15 @@ list(APPEND kdenlive_SRCS
   KoSliderCombo.cpp
   abstractclipitem.cpp
   abstractgroupitem.cpp
-  abstractmonitor.cpp
-  archivewidget.cpp
-  choosecolorwidget.cpp
   clipdurationdialog.cpp
   clipitem.cpp
   clipmanager.cpp
   clipproperties.cpp
   cliptranscode.cpp
   clipstabilize.cpp
-  colorpickerwidget.cpp
   colorplaneexport.cpp
   colortools.cpp
   complexparameter.cpp
-  cornerswidget.cpp
   customruler.cpp
   customtrackscene.cpp
   customtrackview.cpp
@@ -132,7 +127,6 @@ list(APPEND kdenlive_SRCS
   docclipbase.cpp
   documentchecker.cpp
   documentvalidator.cpp
-  doubleparameterwidget.cpp
   dragvalue.cpp
   dvdwizard.cpp
   dvdwizardchapters.cpp
@@ -140,13 +134,11 @@ list(APPEND kdenlive_SRCS
   dvdwizardvob.cpp
   effectslist.cpp
   effectslistview.cpp
-  effectslistwidget.cpp
   effectstackedit.cpp
   encodingprofilesdialog.cpp
   folderprojectitem.cpp
   gentime.cpp
   geometryval.cpp
-  geometrywidget.cpp
   graphicsscenerectmove.cpp
   guide.cpp
   headertrack.cpp
@@ -156,16 +148,13 @@ list(APPEND kdenlive_SRCS
   keyframeedit.cpp
   keyframehelper.cpp
   kis_cubic_curve.cpp
-  kis_curve_widget.cpp
   kthumb.cpp
   managecapturesdialog.cpp
   markerdialog.cpp
   mltdevicecapture.cpp
   monitor.cpp
-  monitoreditwidget.cpp
   monitormanager.cpp
   monitorscene.cpp
-  noteswidget.cpp
   parameterplotter.cpp
   positionedit.cpp
   profilesdialog.cpp
@@ -175,7 +164,6 @@ list(APPEND kdenlive_SRCS
   projectsettings.cpp
   recmonitor.cpp
   renderer.cpp
-  renderwidget.cpp
   slideshowclip.cpp
   smallruler.cpp
   spacerdialog.cpp
@@ -184,7 +172,6 @@ list(APPEND kdenlive_SRCS
   timecode.cpp
   timecodedisplay.cpp
   titledocument.cpp
-  titlewidget.cpp
   trackdialog.cpp
   tracksconfigdialog.cpp
   trackview.cpp
@@ -272,7 +259,7 @@ kde4_add_ui_files(kdenlive_UIS
 )
 
 if(OPENGL_FOUND)
-  list(APPEND kdenlive_SRCS videoglwidget.cpp)
+  list(APPEND kdenlive_SRCS widgets/videoglwidget.cpp)
 endif(OPENGL_FOUND)
 
 if(BUILD_JogShuttle)
@@ -308,6 +295,8 @@ include_directories(
   ${KDE4_INCLUDES} # Adds Qt include directories too.
   ${LIBMLT_INCLUDE_DIR}
   ${LIBMLTPLUS_INCLUDE_DIR}
+  ${CMAKE_CURRENT_SOURCE_DIR}/lib/external 
+  ${CMAKE_CURRENT_SOURCE_DIR}/lib 
 )
 
 
@@ -333,6 +322,7 @@ target_link_libraries(kdenlive
   ${LIBMLTPLUS_LIBRARY}
   ${CMAKE_DL_LIBS}
   ${CMAKE_THREAD_LIBS_INIT}
+  kiss_fft
 )
 
 if(Q_WS_X11)
@@ -375,6 +365,9 @@ endif(BUILD_V4L)
 
 if(BUILD_JogShuttle)
   add_definitions(-DUSE_JOGSHUTTLE)
+  target_link_libraries(kdenlive
+    media_ctrl
+  )
 endif(BUILD_JogShuttle)
 
 install(TARGETS kdenlive DESTINATION ${BIN_INSTALL_DIR})