]> git.sesse.net Git - bcachefs-tools-debian/commitdiff
rust: bump rpassword to v7.x
authorFaidon Liambotis <paravoid@debian.org>
Tue, 9 Jan 2024 10:53:00 +0000 (12:53 +0200)
committerKent Overstreet <kent.overstreet@linux.dev>
Tue, 16 Jan 2024 21:30:10 +0000 (16:30 -0500)
Including a tiny API change.

Signed-off-by: Kent Overstreet <kent.overstreet@linux.dev>
Cargo.lock
Cargo.toml
src/key.rs

index 3e7eea92f8003eb14b4edc4e92c693c35798bc46..cf561fb7cbc1a5e9402037d81f1386875d94933f 100644 (file)
@@ -536,12 +536,23 @@ checksum = "c08c74e62047bb2de4ff487b251e4a92e24f48745648451635cec7d591162d9f"
 
 [[package]]
 name = "rpassword"
-version = "4.0.5"
+version = "7.3.1"
 source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "99371657d3c8e4d816fb6221db98fa408242b0b53bac08f8676a41f8554fe99f"
+checksum = "80472be3c897911d0137b2d2b9055faf6eeac5b14e324073d83bc17b191d7e3f"
 dependencies = [
  "libc",
- "winapi",
+ "rtoolbox",
+ "windows-sys 0.48.0",
+]
+
+[[package]]
+name = "rtoolbox"
+version = "0.0.2"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+checksum = "c247d24e63230cdb56463ae328478bd5eac8b8faa8c69461a77e8e323afac90e"
+dependencies = [
+ "libc",
+ "windows-sys 0.48.0",
 ]
 
 [[package]]
index 66d7bc6a5bf8f2f0a0af7f44f2acb295f23d6fd3..e5478e6de7c36726c69086d9051ef4bea62bff37 100644 (file)
@@ -22,6 +22,6 @@ uuid = "1.2.2"
 gag = "1.0.0"
 errno = "0.2"
 either = "1.5"
-rpassword = "4"
+rpassword = "7"
 bch_bindgen = { path = "bch_bindgen" }
 byteorder = "1.3"
index 93daa2637168c3f7e4b37c400e4c07b4ed0b2a15..de8470db4d078131c54839f4832929f56a61392b 100644 (file)
@@ -87,7 +87,7 @@ fn ask_for_key(sb: &bch_sb_handle) -> anyhow::Result<()> {
     let bch_key_magic = BCH_KEY_MAGIC.as_bytes().read_u64::<LittleEndian>().unwrap();
     let crypt = sb.sb().crypt().unwrap();
     let pass = if atty::is(atty::Stream::Stdin) {
-        rpassword::read_password_from_tty(Some("Enter passphrase: "))?
+        rpassword::prompt_password("Enter passphrase: ")?
     } else {
         let mut line = String::new();
         std::io::stdin().read_line(&mut line)?;