]> git.sesse.net Git - bcachefs-tools-debian/commitdiff
nix: fix build
authorWill Fancher <elvishjerricco@gmail.com>
Sun, 21 Jan 2024 22:16:51 +0000 (17:16 -0500)
committerWill Fancher <elvishjerricco@gmail.com>
Tue, 23 Jan 2024 07:38:20 +0000 (02:38 -0500)
build.nix

index a37a6c6ee774f4872989b01672dc33c47ccdef6b..a7383d1b418b4a832d472ce8e33af044092b55e6 100644 (file)
--- a/build.nix
+++ b/build.nix
@@ -33,7 +33,7 @@ in stdenv.mkDerivation {
     udev
   ] ++ lib.optional fuseSupport fuse3;
 
-  BCACHEFS_FUSE = if fuseSupport then "1" else "";
+  ${if fuseSupport then "BCACHEFS_FUSE" else null} = "1";
 
   cargoRoot = ".";
   # when git-based crates are updated, run:
@@ -49,7 +49,7 @@ in stdenv.mkDerivation {
   makeFlags = [ "DESTDIR=${placeholder "out"}" "PREFIX=" "VERSION=${commit}" ];
 
   dontStrip = true;
-  checkPhase = "./bcachefs version";
+  checkPhase = "./target/release/bcachefs version";
   doCheck = true;
 
   meta = {