]> git.sesse.net Git - bcachefs-tools-debian/commitdiff
Make initramfs hook install mount.bcachefs
authorSteinar H. Gunderson <steinar+git@gunderson.no>
Sat, 3 Feb 2024 09:45:00 +0000 (10:45 +0100)
committerSteinar H. Gunderson <sgunderson@bigfoot.com>
Sun, 4 Feb 2024 13:44:54 +0000 (14:44 +0100)
Now that the bcachefs tool unconditionally includes the mount parts
(or more correctly, you cannot build it at all if you don't have Rust),
we can call copy_exec on mount.bcachefs, to get the symlink installed.
In particular, this helps with mounting UUID mounts as /.

See also https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1060411
for the remaining parts needed in initramfs-tools itself.

Makefile
initramfs/hook

index 392347914002d44608dc63a201317bd8a7f35df6..80d24ff931d1f3cd1437dfa47e1547b10565d8ea 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -214,6 +214,7 @@ install: bcachefs $(optional_install)
 
        sed -i '/^# Note: make install replaces/,$$d' $(DESTDIR)$(INITRAMFS_HOOK)
        echo "copy_exec $(ROOT_SBINDIR)/bcachefs /sbin/bcachefs" >> $(DESTDIR)$(INITRAMFS_HOOK)
+       echo "copy_exec $(ROOT_SBINDIR)/mount.bcachefs /sbin/mount.bcachefs" >> $(DESTDIR)$(INITRAMFS_HOOK)
 
 .PHONY: install_systemd
 install_systemd: $(systemd_services) $(systemd_libexecfiles)
index c172dbdbbd32bc2dd466bb09436827c852818bda..00ab52fa9d1b1e16aef4a84149213569ff4d2a2e 100755 (executable)
@@ -25,3 +25,4 @@ add_loaded_modules 'poly1305[-_]*'
 # Add the bcachefs utility to the initramfs
 # Note: make install replaces this with the install path, so it must be last
 #copy_exec /usr/local/sbin/bcachefs /sbin/bcachefs
+#copy_exec /usr/local/sbin/mount.bcachefs /sbin/mount.bcachefs