]> git.sesse.net Git - bcachefs-tools-debian/commitdiff
fix(build): clean should delete top-level libbcachefs.a
authorRyan Lahfa <bcachefs@lahfa.xyz>
Sat, 27 Jan 2024 03:30:00 +0000 (04:30 +0100)
committerRyan Lahfa <bcachefs@lahfa.xyz>
Sat, 27 Jan 2024 04:15:19 +0000 (05:15 +0100)
I spent some minutes pestering Kent about weird counters issues, when, actually, `make clean`
was keeping this artifact on my filesystem.

Signed-off-by: Ryan Lahfa <bcachefs@lahfa.xyz>
Makefile

index dce6c535bb1e3bb438392892b0c8cc9d943e5bce..392347914002d44608dc63a201317bd8a7f35df6 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -223,7 +223,7 @@ install_systemd: $(systemd_services) $(systemd_libexecfiles)
 .PHONY: clean
 clean:
        @echo "Cleaning all"
-       $(Q)$(RM) c_src/libbcachefs.a tests/test_helper .version *.tar.xz $(OBJS) $(DEPS) $(DOCGENERATED)
+       $(Q)$(RM) libbcachefs.a c_src/libbcachefs.a tests/test_helper .version *.tar.xz $(OBJS) $(DEPS) $(DOCGENERATED)
        $(Q)$(CARGO_CLEAN)
        $(Q)$(RM) -f $(built_scripts)