Use extendable instead of depth extension